This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 134534 - X11 forwarding broken with Solaris 8.
X11 forwarding broken with Solaris 8.
Status: CLOSED DUPLICATE of bug 137685
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openssh (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-04 10:51 EDT by Marc Wallman
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-31 16:32:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Wallman 2004-10-04 10:51:03 EDT
Description of problem:

Remote display of X apps via SSH X11 forwarding fails when remote host
is Solaris 8.

Regular X display using xhost mechanism works properly.

Windows forwarded over SSH from RHEL 2.1 and 3 do pop up but don't
appear to render properly.

Version-Release number of selected component (if applicable):

xorg-x11-6.8.0-4
openssh-clients-3.9p1-3

How reproducible:

Every time

Steps to Reproduce:
1. Ssh to remote solaris 8 host
2. run xclock
3.
  
Actual results:

xclock is /usr/openwin/bin/xclock
abacus $ xclock
X Error of failed request:  BadDrawable (invalid Pixmap or Window
parameter)
  Major opcode of failed request:  55 (X_CreateGC)
  Resource id in failed request:  0x2a00000
  Serial number of failed request:  1
  Current serial number in output stream:  3
abacus $


Expected results:

An x clock should show up.

Additional info:

I couldn't find xorg-x11 in the package list so I'm attaching it to
openssh.

Here's the contents of /etc/ssh/ssh_config:

Host *
        GSSAPIAuthentication yes
        ForwardAgent yes
        ForwardX11 yes
Comment 1 Barry K. Nathan 2004-10-05 07:38:01 EDT
Try using the -Y option with ssh, and let us know whether that works.
Comment 2 Marc Wallman 2004-10-06 10:11:45 EDT
Yes, the -Y option works. Fixes the problem on solaris and causes
windows from remote RHEL 2.1 and 3 to render properly. Looks this is
new to 3.9p1, or at least was not yet in openssh as of 3.6.1p2 which
shipped with RHEL v3.
Comment 3 Barry K. Nathan 2004-10-06 15:03:40 EDT
OpenSSH 3.8 added support for the X11 Security extension, but support
for that isn't fully properly implemented throughout the Linux/Unix
world yet...
Comment 4 Tomas Mraz 2005-01-31 16:31:16 EST

*** This bug has been marked as a duplicate of 137685 ***

Note You need to log in before you can comment on or make changes to this bug.