Bug 134547 - Need a .desktop file shipped as part of xmms
Need a .desktop file shipped as part of xmms
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-menus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-10-04 11:30 EDT by Christopher Aillon
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.10-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-13 16:41:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Aillon 2004-10-04 11:30:24 EDT
Description of problem:

rpm -e rhythmbox;
yum install xmms;

Open nautilus and click on an .ogg or .mp3 file, etc.  Nothing
happens.  We need to ship a .desktop file with xmms with the
appropriate MimeType entry.  See
http://fedora.linux.duke.edu/wiki/NewMIMESystem
Comment 1 Bryan W Clark 2004-10-04 11:42:09 EDT
It appears to already have the MIME types in the .desktop file...
probably isn't running the desktop-file-utils progs during install.

redhat-audio-player.desktop
...
MimeType=audio/x-mp3;audio/x-mod;audio/x-wav;audio/x-mpegurl;
audio/mpegurl;audio/x-scpls;application/x-ogg;

Since XMMS isn't part of our default install we should transition the
name over to Name=XMMS Audio Player, however we don't need translation
hunting us down for this one so it can probably wait.
Comment 2 Jef Spaleta 2004-10-12 00:18:29 EDT
hmmm i think the mime type list in the xmms desktop file might have a
syntax error. You might have to add application/ogg;  to get it to
show up in nautilus for oggs. 

i just installed xmms from the development tree
and the postinstall script does the call to 
update-desktop-database /usr/share/applications
and I see the Mime-type definition
but....
xmms is not showing up in the right click menu in nautilus for ogg
files as a choice. Nor does it show up in the "Open With" tab of the
file propreties dialog.
but....
It does show up in the wav files as a choice.

Here is a comparison between rhythmbox and xmms Mime types, you might
consider adding more than the application/ogg. I'm pretty sure xmms
can do flac as well even if it does take a plugin.

/usr/share/applications/rhythmbox.desktop:
MimeType=application/x-ogg;application/ogg;audio/x-mp3;
audio/x-scpls;audio/x-mp3;audio/x-mpeg;audio/mpeg;
audio/x-mpegurl;application/x-flac

/usr/share/applications/redhat-audio-player.desktop
MimeType=audio/x-mp3;audio/x-mod;audio/x-wav;
audio/x-mpegurl;audio/mpegurl;audio/x-scpls;application/x-ogg;

-jef
Comment 3 Colin Walters 2004-10-13 16:43:13 EDT
There were actually two bugs here:
1) missing application/ogg from the redhat-audio-player.desktop
2) xmms calling update-desktop-database /usr/share/applications
instead of update-desktop-database /usr/share/desktop-menu-patches

Both are fixed.

Note You need to log in before you can comment on or make changes to this bug.