Bug 1345748 - SAMBA-DHT : Crash seen while rename operations in cifs mount and windows access of share mount
Summary: SAMBA-DHT : Crash seen while rename operations in cifs mount and windows acce...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Raghavendra G
QA Contact:
URL:
Whiteboard:
Depends On: 1345732
Blocks: 1366482 1366483
TreeView+ depends on / blocked
 
Reported: 2016-06-13 06:37 UTC by Raghavendra G
Modified: 2017-03-27 18:18 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1345732
: 1366482 1366483 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:18:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-06-13 06:58:20 UTC
REVIEW: http://review.gluster.org/14707 (cluster/dht: initial cbk before attempting inode-link) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 2 Vijay Bellur 2016-06-13 06:59:01 UTC
REVIEW: http://review.gluster.org/14707 (cluster/dht: initialize cbk before attempting inode-link) posted (#2) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 3 Raghavendra G 2016-06-13 07:12:36 UTC
(In reply to Vijay Bellur from comment #2)
> REVIEW: http://review.gluster.org/14707 (cluster/dht: initialize cbk before
> attempting inode-link) posted (#2) for review on master by Raghavendra G
> (rgowdapp@redhat.com)

Though this patch fixes the crash. Bigger question is how did loc->parent happen to contain "samba2". The rename is done in root directory and hence if there is a lookup on ".samba2", loc->parent should've been root.

1. We need more information on smb traffic during the test
2. Probably there is a bug in higher layers (smb-server, gfapi, smb-client etc) which fill wrong loc->parent (not ruling out dht is not modifying loc->parent, but highly unlikely).

regards,
Raghavendra

Comment 4 Vijay Bellur 2016-06-14 04:03:36 UTC
REVIEW: http://review.gluster.org/14707 (cluster/dht: initialize cbk before attempting inode-link) posted (#3) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 5 Vijay Bellur 2016-06-17 12:23:54 UTC
COMMIT: http://review.gluster.org/14707 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit a4d35ccb8afeefae4d9cdd36ac19b0e97d0d04d0
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Mon Jun 13 12:26:24 2016 +0530

    cluster/dht: initialize cbk before attempting inode-link
    
    Otherwise inode-link failures in selfheal codepath will result in a
    crash.
    
    Change-Id: I9061629ae9d1eb1ac945af5f448d0d8b397a5022
    BUG: 1345748
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: http://review.gluster.org/14707
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Poornima G <pgurusid@redhat.com>
    Reviewed-by: Susant Palai <spalai@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 6 Shyamsundar 2017-03-27 18:18:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.