Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1345772 - [ALL LANG] Unexpected error 'undefined method `new_link' for #<#<Class:0x007f170e5f5ee8>:0x007f170e568750>' in Containers -> Registries.
Summary: [ALL LANG] Unexpected error 'undefined method `new_link' for #<#<Class:0x007f...
Keywords:
Status: CLOSED DUPLICATE of bug 1333805
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Localization and Internationalization
Version: 6.2.0
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-13 07:20 UTC by Lijun Li
Modified: 2019-04-01 20:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-15 20:43:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
Unexpected error 'undefined method `new_link' for #<#<Class:0x007f170e5f5ee8>:0x007f170e568750>' in Containers -> Registries (16.90 KB, image/png)
2016-06-13 07:21 UTC, Lijun Li
no flags Details

Description Lijun Li 2016-06-13 07:20:13 UTC
Description of problem:
[ALL LANG] Unexpected error 'undefined method `new_link' for #<#<Class:0x007f170e5f5ee8>:0x007f170e568750>' in Containers -> Registries.

Version-Release number of selected component (if applicable):
Satellite 6.2.0 GA Snap 12.0

How reproducible:
100%

Steps to Reproduce:
1. Access Satellite login page with target locale.
2. Click Containers -> Registries.

Actual results:
[ALL LANG] Unexpected error 'undefined method `new_link' for #<#<Class:0x007f170e5f5ee8>:0x007f170e568750>' in Containers -> Registries.

Expected results:
The Registries page should be displayed as normal.

Additional info:
Please see the attached screen-shot.

Comment 1 Lijun Li 2016-06-13 07:21:04 UTC
Created attachment 1167252 [details]
Unexpected error 'undefined method `new_link' for #<#<Class:0x007f170e5f5ee8>:0x007f170e568750>' in Containers -> Registries

Comment 3 Brad Buckingham 2016-06-15 20:43:05 UTC
It looks like the 'new_link' error was also raised in https://bugzilla.redhat.com/show_bug.cgi?id=1333805#c8 .  The solution was included and verified with Satellite 6.2 SNAP 13.  I am going to close this bug as a duplicate; however, if you see the issue again on a newer build, please do reopen.  Thanks!

*** This bug has been marked as a duplicate of bug 1333805 ***


Note You need to log in before you can comment on or make changes to this bug.