Bug 1345826 - once-test fails on ppc64/ppc64le arches
Summary: once-test fails on ppc64/ppc64le arches
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: rawhide
Hardware: ppc64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2016-06-13 09:26 UTC by Dan Horák
Modified: 2017-01-17 12:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-22 15:27:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 96638 None None None 2017-01-17 12:30:00 UTC

Description Dan Horák 2016-06-13 09:26:33 UTC
The once-test fails for 8.99 versions on ppc64/ppc64le arches.

see http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=3455938 for full logs


Version-Release number of selected component (if applicable):
pulseaudio-8.99.2-1.fc25

Additional info:
IIRC there was such bug in the past, ppc specific, should not be endian one because builds OK on s390x.

Comment 1 Dan Horák 2016-06-13 09:40:09 UTC
seems to be rawhide specific, can't reproduce it on ppc64 F-24

Comment 2 Rex Dieter 2016-06-13 16:11:26 UTC
in pulseaudio-8.99.2-2, made tests non-fatal and to echo the contents of test-suite.log in case of errors.

Comment 3 Dan Horák 2016-06-13 16:54:24 UTC
from http://ppc.koji.fedoraproject.org/kojifiles/packages/pulseaudio/8.99.2/2.fc25/data/logs/ppc64/

...
FAIL: once-test
===============
Running suite(s): Once
0%: Checks: 1, Failures: 1, Errors: 0
tests/once-test.c:74:F:once:once_test:0: Assertion 'pthread_setaffinity_np(pthread_self(), sizeof(mask), &mask) == 0' failed
FAIL once-test (exit status: 1)


maybe it was systemd what had the same issue ...

Comment 4 Ngo Than 2016-06-22 15:27:25 UTC
it's fixed in pulseaudio-8.99.2-3.fc25

Comment 5 Rex Dieter 2017-01-06 14:47:34 UTC
Than, could you try upstreaming this fix?  If not upstreamable, why not?

Comment 6 Ngo Than 2017-01-17 11:10:57 UTC
(In reply to Rex Dieter from comment #5)
> Than, could you try upstreaming this fix?  If not upstreamable, why not?

as i remember correctly i already report this issue with the patch to upstream. I will check again.

Comment 7 Ngo Than 2017-01-17 12:23:21 UTC
i reported the bug with the patch to upstream by 2016-06-22 16:03:45 UTC , and there's no activity from upstream, status is still on new!

https://bugs.freedesktop.org/show_bug.cgi?id=96638

Comment 8 Rex Dieter 2017-01-17 12:30:00 UTC
Thanks, I'll make a reference to that here and in the .spec


Note You need to log in before you can comment on or make changes to this bug.