Bug 1346010 - Introduce API support for requesting mandatory locks
Summary: Introduce API support for requesting mandatory locks
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: mainline
Hardware: All
OS: All
medium
medium
Target Milestone: ---
Assignee: Anoop C S
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On:
Blocks: 1346013 1348975
TreeView+ depends on / blocked
 
Reported: 2016-06-13 16:21 UTC by Anoop C S
Modified: 2018-01-17 05:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1346013 1348975 (view as bug list)
Environment:
Last Closed: 2018-01-17 05:17:50 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github https://github.com/gluster glusterfs issues 393 0 None None None 2018-01-17 05:12:05 UTC

Description Anoop C S 2016-06-13 16:21:34 UTC
Description of problem:
In spite of having the mandatory-locks feature for GlusterFS, its native C API lacks support for requesting the same. This bug is to track the implementation/extension of libgfapi to provide this support for applications.

Version-Release number of selected component (if applicable):
mainline

Comment 1 Vijay Bellur 2016-06-15 06:03:29 UTC
REVIEW: http://review.gluster.org/11177 (libgfapi: Add new api for supporting mandatory-locks) posted (#17) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 2 Vijay Bellur 2016-07-08 09:58:16 UTC
REVIEW: http://review.gluster.org/11177 (libgfapi: Add new api for supporting mandatory-locks) posted (#19) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 3 Vijay Bellur 2016-07-15 14:03:55 UTC
REVIEW: http://review.gluster.org/11177 (libgfapi: Add new api for supporting mandatory-locks) posted (#20) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 4 Worker Ant 2017-07-28 10:34:18 UTC
REVIEW: https://review.gluster.org/11177 (libgfapi: Add new api for supporting mandatory-locks) posted (#21) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 5 Anoop C S 2018-01-17 05:11:03 UTC
This will be tracked in future via https://github.com/gluster/glusterfs/issues/393. So closing out the bug report.


Note You need to log in before you can comment on or make changes to this bug.