Bug 1346049 - orocos-bfl FTBFS on aarch64 epel7
Summary: orocos-bfl FTBFS on aarch64 epel7
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: orocos-bfl
Version: epel7
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Till Hofmann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: epel7aarch64
TreeView+ depends on / blocked
 
Reported: 2016-06-13 19:07 UTC by D. Marlin
Modified: 2016-06-30 09:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-30 09:56:44 UTC
Type: Bug


Attachments (Terms of Use)
SRPM with correct ExcludeArch (275.92 KB, application/x-rpm)
2016-06-29 17:46 UTC, Till Hofmann
no flags Details

Description D. Marlin 2016-06-13 19:07:59 UTC
Description of problem:

orocos-bfl fails to build from source for Fedora EPEL7 on RHELSA-7.2.


Version-Release number of selected component (if applicable):

orocos-bfl-0.8.99-5.20160503gitc1b18e3.el7


How reproducible:

consistently


Steps to Reproduce:
1.  On a RHELSA-7.2 host:
     mock -r epel-7-aarch64 orocos-bfl-0.8.99-5.20160503gitc1b18e3.el7.src.rpm
2.
3.

Actual results:

test 5
    Start 5: test_model

5: Test command: /builddir/build/BUILD/orocos-bayesian-filtering.git/orocos_bfl/tests/test_model
5: Test timeout computed to be: 9.99988e+06
5: .F..
5: 
5: model_test.cpp:99:Assertion
5: Test name: ModelTest::testDiscreteSystemModel
5: equality assertion failed
5: - Expected: 0.98
5: - Actual  : 0.005
5: 
5: Failures !!!
5: Run: 3   Failure total: 1   Failures: 1   Errors: 0
5/8 Test #5: test_model .......................***Failed    0.01 sec


Expected results:

build completes without test failures.


Additional info:

Comment 1 Till Hofmann 2016-06-13 20:18:46 UTC
The exact same error occurs on arm, which is why this package is not built for arm, as noted in the Spec file.

I reported the issue upstream: http://bugs.orocos.org/show_bug.cgi?id=1062
I do not expect upstream to fix this anytime soon.

Should I add ExcludeArch: aarch64 ?

Comment 2 D. Marlin 2016-06-14 23:45:25 UTC
(In reply to Till Hofmann from comment #1)
> The exact same error occurs on arm, which is why this package is not built
> for arm, as noted in the Spec file.
> 
> I reported the issue upstream: http://bugs.orocos.org/show_bug.cgi?id=1062
> I do not expect upstream to fix this anytime soon.
> 
> Should I add ExcludeArch: aarch64 ?

Yes, please.  We can revisit this when there is an upstream fix.

Comment 3 Fedora Update System 2016-06-15 07:20:14 UTC
orocos-bfl-0.8.99-6.20160503gitc1b18e3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-45a9108df2

Comment 4 Fedora Update System 2016-06-16 15:18:49 UTC
orocos-bfl-0.8.99-6.20160503gitc1b18e3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-45a9108df2

Comment 5 D. Marlin 2016-06-29 15:26:41 UTC
Using orocos-bfl-0.8.99-6.20160503gitc1b18e3.el7.src.rpm, I am still seeing the same test failure on AArch64.

Comment 6 Till Hofmann 2016-06-29 17:46:41 UTC
Created attachment 1174132 [details]
SRPM with correct ExcludeArch

Comment 7 Till Hofmann 2016-06-29 17:47:36 UTC
There was a typo in the Spec file, there is no %{aarch64} macro, I replaced it with 'ExcludeArch: aarch64'. Can you please try the attached SRPM?

Comment 8 D. Marlin 2016-06-29 22:27:39 UTC
I downloaded the attached SRPM and tried another build:

   Start: rpmbuild orocos-bfl-0.8.99-6.20160503gitc1b18e3.el7.src.rpm
   error: Architecture is excluded: aarch64

It works as expected.

Comment 9 Till Hofmann 2016-06-30 09:56:44 UTC
Thank you for the feedback, I pushed the change. I think a rebuild was actually unnecessary because there are no changes for any other arch. I unpushed the old update and I won't push a new update, but any new build will skip aarch64 from now on.

Closing as WONTFIX because simply skipping aarch64 doesn't really fix the issue.


Note You need to log in before you can comment on or make changes to this bug.