Bug 1346054 - python-hardware-detect missing dependency[osp-10]
Summary: python-hardware-detect missing dependency[osp-10]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-hardware
Version: 8.0 (Liberty)
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: beta
: 10.0 (Newton)
Assignee: Steve Linabery
QA Contact: Dmitry Tantsur
URL:
Whiteboard:
Depends On:
Blocks: 1346275 1346277
TreeView+ depends on / blocked
 
Reported: 2016-06-13 19:22 UTC by Dimitri Savineau
Modified: 2016-12-14 15:39 UTC (History)
8 users (show)

Fixed In Version: python-hardware-0.17.1-0.20160614153452.790d92a.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1346275 (view as bug list)
Environment:
Last Closed: 2016-12-14 15:39:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
RDO 1390 None None None 2016-06-15 13:16:36 UTC

Description Dimitri Savineau 2016-06-13 19:22:51 UTC
Description of problem:
Can't run hardware-detect

Version-Release number of selected component (if applicable):
# rpm -qa python-hardware-detect
python-hardware-detect-0.17-6.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. install the package
2. run the hardware detection

Actual results:
# yum install -y python-hardware-detect
# hardware-detect 
Traceback (most recent call last):
  File "/bin/hardware-detect", line 6, in <module>
    from hardware.detect import main
  File "/usr/lib/python2.7/site-packages/hardware/__init__.py", line 15, in <module>
    import pbr.version
ImportError: No module named pbr.version

Expected results:
A working hardware detection

Additional info:
Installing python-pbr package solves the issue

Comment 2 Mike Burns 2016-06-14 13:33:03 UTC
http://review.rdoproject.org/r/1390

Comment 3 Jon Schlueter 2016-06-14 14:30:22 UTC
https://review.rdoproject.org/r/#/c/1390/ - for rpm master merged

Comment 5 Dmitry Tantsur 2016-10-17 07:54:35 UTC
The dependency is present in a recent puddle:

[stack@host07 ~]$ rpm -q python-hardware-detect
python-hardware-detect-0.18.1-0.20161003155245.e36c931.el7ost.noarch
[stack@host07 ~]$ rpm -qR python-hardware-detect | grep pbr
python-pbr

I can also verity that the command works as expected, both locally and on the introspection ramdisk.

Comment 8 errata-xmlrpc 2016-12-14 15:39:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.