Bug 1346112 - systemtap-server SSL/TLS certificates needs to be unique per instance or install but this value is created at install-time and not during the first run.
Summary: systemtap-server SSL/TLS certificates needs to be unique per instance or inst...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemtap
Version: 7.1
Hardware: All
OS: All
high
medium
Target Milestone: rc
: ---
Assignee: Frank Ch. Eigler
QA Contact: Martin Cermak
URL:
Whiteboard:
Depends On:
Blocks: 1346019
TreeView+ depends on / blocked
 
Reported: 2016-06-14 02:58 UTC by Kurt Seifried
Modified: 2016-11-04 04:36 UTC (History)
6 users (show)

Fixed In Version: systemtap-3.0-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1378462 (view as bug list)
Environment:
Last Closed: 2016-11-04 04:36:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2358 0 normal SHIPPED_LIVE systemtap bug fix and enhancement update 2016-11-03 13:49:05 UTC

Description Kurt Seifried 2016-06-14 02:58:19 UTC
Version-Release number of selected component (if applicable):

systemtap-2.8-10.el7

postinstall:
# If it does not already exist, as stap-server, generate the certificate
# used for signing and for ssl.
if test ! -e ~stap-server/.systemtap/ssl/server/stap.cert; then
   runuser -s /bin/sh - stap-server -c /usr/libexec/systemtap/stap-gen-cert >/dev/null
fi

which is in /var/lib/stap-server/.systemtap/ssl/server/stap.cert


How reproducible:

Always.
p

Steps to Reproduce:
1. Install to a container or image.
2. Run new instance of container or image.
3.

Actual results:

All container and image instances share the same key/certificate.

Expected results:

Each instance should receive a unique key/certificate.

Additional info:

This bug is being file because Product Security considers "first run problems" to be bugs with the source package and with the container or image only in the aggregate. This view is in collaboration with upstream Fedora. See: https://fedorahosted.org/fpc/ticket/506

The recommended resolution for services is to follow the "First-time Service Setup" pattern (see: https://fedoraproject.org/wiki/Packaging:Initial_Service_Setup ). Other packages may should use a runtime check and generation or similar procedure.

Comment 2 Frank Ch. Eigler 2016-06-15 15:10:46 UTC
upstream commit be665e77eb7c

Comment 8 errata-xmlrpc 2016-11-04 04:36:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2358.html


Note You need to log in before you can comment on or make changes to this bug.