Bug 1346134 - quota : rectify quota-deem-statfs default value in gluster v set help command
Summary: quota : rectify quota-deem-statfs default value in gluster v set help command
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: 3.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Manikandan
QA Contact:
URL:
Whiteboard:
Depends On: 1345846 1346184 1354260
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-14 05:59 UTC by Manikandan
Modified: 2016-09-20 04:29 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1345846
Environment:
Last Closed: 2016-07-08 14:43:58 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Manikandan 2016-06-14 05:59:37 UTC
+++ This bug was initially created as a clone of Bug #1345846 +++

Description of problem:
quota-deem-statfs volume option is on by default. But the volume set option shows off as default value.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. gluster v set help | grep quota


Actual results:
Option: features.quota-deem-statfs
Description: If set to on, it takes quota limits intoconsideration while estimating fs size. (df command) (Default is off).


Expected results:
Option: features.quota-deem-statfs
Description: If set to on, it takes quota limits intoconsideration while estimating fs size. (df command) (Default is on).



Additional info:

--- Additional comment from Vijay Bellur on 2016-06-13 06:16:53 EDT ---

REVIEW: http://review.gluster.org/14708 (quota : rectify quota-deem-statfs default settings) posted (#2) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-06-14 01:51:33 EDT ---

COMMIT: http://review.gluster.org/14708 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit c158742fb52ae1f6d3576c64caf42b67d784a3e3
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Mon Jun 13 15:28:41 2016 +0530

    quota : rectify quota-deem-statfs default settings
    
    Change-Id: I75c47c4a0f0eb898b5e32efe7f0a6a558d7f8007
    BUG: 1345846
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/14708
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 1 Vijay Bellur 2016-06-14 07:36:33 UTC
REVIEW: http://review.gluster.org/14726 (quota : rectify quota-deem-statfs default settings) posted (#1) for review on release-3.8 by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 2 Vijay Bellur 2016-06-14 09:07:47 UTC
REVIEW: http://review.gluster.org/14726 (quota : rectify quota-deem-statfs default settings) posted (#2) for review on release-3.8 by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 3 Vijay Bellur 2016-06-15 11:22:45 UTC
COMMIT: http://review.gluster.org/14726 committed in release-3.8 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 457ece66327451decd89281d2808f2aa8ba94b60
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Mon Jun 13 15:28:41 2016 +0530

    quota : rectify quota-deem-statfs default settings
    
    Backport of http://review.gluster.org/#/c/14708/
    
    When quota is enabled, quota-deem-statfs is on by default.
    This is not updated in gluster v set help command. With, the
    patch, the description of deem statfs command is updated.
    
    > Change-Id: I75c47c4a0f0eb898b5e32efe7f0a6a558d7f8007
    > BUG: 1345846
    > Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    > Reviewed-on: http://review.gluster.org/14708
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    
    Change-Id: I75c47c4a0f0eb898b5e32efe7f0a6a558d7f8007
    BUG: 1346134
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/14726
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 4 Niels de Vos 2016-07-08 14:43:58 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.1, please open a new bug report.

glusterfs-3.8.1 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.packaging/156
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.