Bug 134616 - 32bit apprication doesn't run on IA32EL.
32bit apprication doesn't run on IA32EL.
Status: CLOSED DUPLICATE of bug 134519
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: glibc (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-04 19:49 EDT by L3support
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L3support 2004-10-04 19:49:59 EDT
Description of problem:
We install ia32el-1.1-2 on RHEL4 beta1 for Itanium and execute a 32bit
application on IA32EL but it ends abnormally.

Version-Release number of selected component (if applicable):
ia32el-1.1-2

How reproducible:
always

Steps to Reproduce:
1. # rpm -ivh ia32el-1.1-2.ia64.rpm
2. # /etc/init.d/ia32el start
3. # strace -f /usr/lib/ia32el/is_ia32el
  
Actual results:
# strace -f /usr/lib/ia32el/is_ia32el
execve("/usr/lib/ia32el/is_ia32el", ["/usr/lib/ia32el/is_ia32el"], [/*
23 vars */]) = 0
futex(0x1, FUTEX_WAKE, 1)               = -1 EINVAL (Invalid argument)
brk(0)                                  = 0x6000000000020000
.
.
.
readlink("/proc/self/fd/3", "/usr/lib/ia32el/is_ia32el", 4096) = 25
pread(3, "/lib/ld-linux.so.2\0", 19, 276) = 19
open("/lib/ld-linux.so.2", O_RDONLY)    = 4
pread(4, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0002\0\1\0\0\0\220-\0"...,
52, 0) = 52
close(4)                                = 0
close(3)                                = 0
exit(-8)                                = ?

Expected results:
32bit application run on IA32EL properly.

Additional info:
Comment 1 Jakub Jelinek 2004-10-05 05:01:16 EDT

*** This bug has been marked as a duplicate of 134519 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.