Bug 134619 - When AllowGroups is used in sshd_config, user is not allowed to login
Summary: When AllowGroups is used in sshd_config, user is not allowed to login
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-05 02:23 UTC by Eric Barry
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-09 13:31:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Barry 2004-10-05 02:23:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
Added the following to my /etc/ssh/sshd_config :
  #echo "AllowGroups sshok" >> /etc/ssh/sshd_config

Added the following to my groups:
  #gpasswd -a eric sshok

(even removed the entry and tried with "groupadd" - same results)

Restarted the service:
  #/etc/rc.d/init.d/sshd restart

Tried to login, met with failure - see output below:

  #tail -3 /var/log/secure
  Oct  4 22:14:03 stanz sshd[2763]: error: Bind to port 22 on 0.0.0.0
failed: Address already in use.
  Oct  4 22:14:12 stanz sshd[2766]: User eric not allowed because none
of user's groups are listed in AllowGroups
  Oct  4 22:14:16 stanz sshd[2766]: Failed unknown for invalid user
eric from ::ffff:192.168.11.22 port 1843 ssh2

  #grep eric /etc/group
  eric:x:500:
  sshok:x:501:eric

  #grep eric /etc/group
  eric:x:500:500:Eric Barry:/home/eric:/bin/bash

  /etc/nsswitch.conf is the default (all files)


If I comment out the AllowGroups option, it works fine and there is
nothing written to the logs...  


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Add group to the list of groups
2.Add user to new group
3.Add "AllowGroups <new group>" to /etc/sshd_config
4.Restart sshd service
5.Try to login
    

Actual Results:  Failed password attempts and errors written to log. 
Disconnect from service.

Expected Results:  Logged in to a session.

Additional info:

Comment 1 Tomas Mraz 2005-02-09 13:31:18 UTC
I can't reproduce it on the current Fedora Core 3 with openssh-3.9p1-7.
If you have some additional info, please reopen.


Comment 2 Eric Barry 2005-02-09 14:00:45 UTC
This was fixed in FC3.  


Note You need to log in before you can comment on or make changes to this bug.