Bug 134620 - gnome-volume-control displays more PCM devices than alsa-mixer
gnome-volume-control displays more PCM devices than alsa-mixer
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-04 22:35 EDT by Erich Hoover
Modified: 2013-03-13 00:46 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.14.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-20 17:31:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
More organized gnome-volume-control (177.66 KB, application/x-gzip)
2004-10-19 20:16 EDT, Erich Hoover
no flags Details
View of several PCM devices (37.74 KB, image/png)
2004-10-20 19:15 EDT, Erich Hoover
no flags Details

  None (edit)
Description Erich Hoover 2004-10-04 22:35:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; rv:1.7.3)
Gecko/20041002 Firefox/0.10.1

Description of problem:
gnome-volume-control displays many more PCM devices that alsa-mixer does.

Version-Release number of selected component (if applicable):
gnome-media-2.8.0-1

How reproducible:
Always

Steps to Reproduce:
1. Use alsamixer from the command prompt to check out PCM devices.
2. Use gnome-volume-control to check out the PCM devices.


Actual Results:  alsamixer shows 4 PCM devices of each type where
gnome-volume-control shows 32, this makes it difficult to determine
which one you want to turn down even if you only have one audio
program running.

Expected Results:  4 PCM devices per type (PCM, PCM Send Routing,
etc.) from both programs.

Additional info:

alsa-lib-1.0.6-1
Sound Blaster Live! Platinum (EMU10K1)
Comment 1 Andrew Farris 2004-10-19 18:03:21 EDT
I have an audigy card also using emu10k1 with similar situation.  Neither
alsa-mixer or gnome-alsamixer (from fedora.us) shows extra entries, however in
gnome-volume-control I have these groups:
30 EMU10K1 PCM (dual slider emu10k1, one under pcm, this is one slider group)
30 EMU10K1 PCM SEND (this is a 12 slider pair group)
30 EMU10K1 PCM Send Routing (this is also a 12 slider pair group)

These appear in groups (the 30 of each type together) after the slider group for
audigy CD, and before "External Amplifier" and "Front", which are the only two
sliders shown after the extraneous ones.  These seem unconnected to anything,
they do not react together when the sliders are moved (one group does not effect
any of the other in the 30).  Whatever is causing the extraneous groups to show
up may be repeating itself, I'll watch to see if more than these 30 keep showing up.

gnome-media-2.8.0-2
alsa-utils-1.0.6-2
gstreamer-0.8.7-3
Comment 2 Erich Hoover 2004-10-19 20:16:23 EDT
Created attachment 105476 [details]
More organized gnome-volume-control

I think this may actually be a problem with the gstreamer component,
gnome-volume-control uses gstreamer to get all of its information and it didn't
appear to be doing anything that could explain this.  The suggested
gnome-alsamixer program does not use the gstreamer component so it does not
experience this problem.  I made some modifications to the gnome-volume-control
program in order to split things up a bit since each mixer device has way too
many controls, the only modified file is gst-mixer/src/mixer.c but I've
included the whole gst-mixer subdirectory from gnome-media.
Comment 3 Colin Walters 2004-10-20 16:19:25 EDT
Erich - Is this bug still a problem with the most recent change
(gnome-media-2.8.0-3) to remove the OSS mixer?

Comment 4 Erich Hoover 2004-10-20 19:15:31 EDT
Created attachment 105563 [details]
View of several PCM devices

I've been playing around with things a little bit - if the most recent change
is identified by "25184 Oct 19 11:58" then it's still a problem (there doesn't
seem to be any identifying version on the volume control component itself). 
One thing is there used to be two tabs and now there aren't any so I'm assuming
it's the new version.  Attached is a view of several of the PCM devices in case
you guys are unable to reproduce the problem, tt seems like only the first few
actually do anything.
Comment 5 Colin Walters 2004-10-21 15:21:01 EDT
This problem seems to be particularly bad the Sound Blaster Live!, which you have.
I will look at your patch.
Comment 6 John Thacker 2006-04-20 17:31:14 EDT
I used to have this bug back around when it was submitted.  I'm pretty sure it's
fixed now, with gnome-media-2.14.0 -- at the very least it WORKSFORME.  I'm
going to close it-- feel free to reopen it if you still have the problem, but
for me it's been fixed for a while.

Note You need to log in before you can comment on or make changes to this bug.