Bug 1346207 - Calamari api /api/v2/cluster/<fsid>/server returns the mon FQDN wrongly with custom mon names in cluster
Summary: Calamari api /api/v2/cluster/<fsid>/server returns the mon FQDN wrongly with ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Calamari
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 2.0
Assignee: Christina Meno
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: 1343229 1346188
TreeView+ depends on / blocked
 
Reported: 2016-06-14 09:24 UTC by Shubhendu Tripathi
Modified: 2016-08-23 19:41 UTC (History)
5 users (show)

Fixed In Version: RHEL: calamari-server-1.4.2-1.el7cp, Ubuntu: calamari_1.4.2-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:41:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1755 0 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Shubhendu Tripathi 2016-06-14 09:24:07 UTC
Description of problem:
If a ceph cluster is created using CLI with custom mon names say mon.a, mon.b, mon.c etc the server listing for a cluster returns the mon FQDN values as "a", "b" and "c".

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a cluster using ceph CLI
2. Invoke the calamari api /api/v2/cluster/<fsid>/server
3.

Actual results:
The mon node FQDB values are listed as "a", "b", "c".... (the suffix of mon.X) in ceph.conf file

Expected results:
The FQDN values should be proper values with full domain names like dhcp46-239.lab.egg.blr.redhat.com

Additional info:
This makes import cluster flow failed in USM as FQDN names are not correctly reported.

Comment 2 Shubhendu Tripathi 2016-06-14 12:03:35 UTC
Raising the severity as URGENT as one use case of import cluster fails in USM..

Comment 3 Christina Meno 2016-06-15 21:19:52 UTC
https://github.com/ceph/calamari/releases/tag/v1.4.2

Comment 6 Shubhendu Tripathi 2016-06-17 12:11:42 UTC
Find this working fine with build calamari-server-1.4.2-1.el7cp.x86_64

Comment 7 Harish NV Rao 2016-06-20 10:20:51 UTC
moving this defect to verified stated based on comment 6

Comment 9 errata-xmlrpc 2016-08-23 19:41:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.