Bug 134625 - Gnome extremely slow after aplication crash
Gnome extremely slow after aplication crash
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-05 03:00 EDT by bednar
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-27 18:11:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bednar 2004-10-05 03:00:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041002
Firefox/0.10.1

Description of problem:
First: I don't know if that is really connected with metacity or maybe
nautilus or libgnome or other!!!

Some apps crashes. That's normal. But when I end one with "Appp not
responding > Close" dialog the Gnome slowes. Mouse, kbd, menus work
normal it is fast. But when I want to rune new app or open new window
of running app I have to wait more tha 10 seconds to see the window.
In between the other windows are somewhat frozen. 

The problem does not appear in KDE.

Solution is to restart X (CTRL+SHIFT+BACKSPACE). But after that the
Gnome often fails to load (this is another bug as I think). So I have
to go to runlevel 3 and then runlevel 5. In the console, when I type
"init 3" I have to switch to another console and back to first to be
able type new command "init 5" (and this is also another bug).




Version-Release number of selected component (if applicable):
metacity-2.8.5-1

How reproducible:
Always

Steps to Reproduce:
1.Close not responding App in gnome
2.Try to run new app, e.g. gedit
3.
    

Actual Results:  Waiting more than 10 second to see new window opened

Expected Results:  New window opened quickly

Additional info:

Toshiba Satellite 1135-S1554 (mobile pentium 4 2.2 GHz, 512 RAM, Intel
85x gfx card, etc.)
I do upgrades everyday. I've been testing FC3test2 since it release.
Comment 1 bednar 2004-10-08 02:17:58 EDT
The problem is still here after upgrades form 07.10.2004 
libgnome-2.8.0-1
metacity-2.8.5-1
kernel-2.6.8-1.541

So the only usable desktop environment at the time is KDE, what AFAIK
is not the default desktop for Fedora.
Comment 2 bednar 2004-10-15 08:58:22 EDT
Hi, after everyday upgrade form rawhide (today is 15.10.2004 it is
four days after FC3TC release) the problem still exists but in rather
slightly form.

Now the problem shows after error in SMB browsing error in Nautilus.
After such error there shows quite big delays in such operations as:
-opening new window
-entering to MenuStart on Panel
the problem does not generate significant CPU load and vanishes after
about a minute. After that Gnome works as it should.
Can somebody confirm this bug?
Comment 3 bednar 2004-11-04 17:30:33 EST
Half day before FC3 final release and the problem persists :(
Comment 4 Havoc Pennington 2004-11-05 01:26:14 EST
I haven't seen this problem or heard of other people having it; how do
you reproduce? Which apps are not responding?
Comment 5 bednar 2004-11-05 03:26:17 EST
Many apps presents same behavor. For example. Start Gnome app (it can
be system-config-display, gthumb, tux-commander or other). Just work
with it for a while. In roandom time the app stops reponding
immediately. It responds but after rather long time (up to minute).
Responding I mean e.g. opening new window from within the app,
entering Start Menu or running other app (e.g. firefox from launcher
placed on gnome-panel). Everything work, but slow. There is amost no
CPU load, just normal CPU load (few %). It seems like waiting for some
timeouts.
This problem (slowness) can be initiated by various gnome apps, but
for example not with Firefox which is (AFAIK) non gnome app. 
Comment 6 Havoc Pennington 2004-11-10 00:22:14 EST
Can you think of anything unusual about your system?
What kinds of things have you installed/configured?
Comment 7 Havoc Pennington 2004-11-10 00:22:39 EST
Any non-default window manager settings? Does changing them back to
defaults help?
Comment 8 bednar 2004-11-10 07:05:09 EST
Yes, I've changed many properties. Among athers it was screen DPI
(which involves other problem with displaying pages in Firefox) and
Font Sizes.
I cannot revert as I just did clean install of FC3 isos. I left
untouched my /home partitions but deleted most of config files
(.gnome2 and others in my ~ dir) before first gnome start.
After gnome start I lost antialias on all fonts except fonts in
gnome-terminal. Changing fonts setting cannot fix it. I had to create
nue user, move important data to new acconut. New user has antialiased
fonts always (but I don't touch the settings now:).

The problem of gnome slowness does not appear in FC3 at all.
Comment 9 Havoc Pennington 2004-11-10 10:15:51 EST
You're saying that the problem disappeared with a clean install of
FC3, but was in FC3test2, right?

Hmm. I don't have any ideas.
Comment 10 bednar 2004-11-17 19:10:16 EST
Yes it did.

But today I've seen it again :(
Comment 11 Ray Strode [halfline] 2005-09-09 15:53:34 EDT
Hi Bednar,

Are you still seeing this problem?
Comment 12 John Thacker 2006-04-27 18:11:59 EDT
No response from reporter for six months to info request.  Closing.

Note You need to log in before you can comment on or make changes to this bug.