Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1346276 - rhts-test-env seemingly results in a Beaker task abort following an extendtesttime.sh update
Summary: rhts-test-env seemingly results in a Beaker task abort following an extendtes...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Beaker
Classification: Retired
Component: tests
Version: develop
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: beaker-dev-list
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-14 12:28 UTC by Kyle Walker
Modified: 2017-12-20 04:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 04:56:10 UTC


Attachments (Terms of Use)

Description Kyle Walker 2016-06-14 12:28:30 UTC
Description of problem:
 Following a reservation extension, a task is shortly thereafter aborted. This is followed by the following messages:

["Event", "output", "3f80b14a-f877-40c2-be2b-60b9107658cb", {"id": "d45ccb17-0437-45cb-99c3-31570e37fd89"}, null, {"data": "/var/lib/beah/tortilla/wrappers.d/runtest: line 3: 10967 Terminated              /usr/bin/rhts-test-runner.sh\n+ rc=143\n+ '[' -n '' ']'\n+ exit 143\n", "out_handle": "stderr"}]
["Event", "lose_item", "24d83034-7cd4-407a-a2a3-945174436796", {"id": "d45ccb17-0437-45cb-99c3-31570e37fd89"}, null, {"data": "2016-06-09 15:41:30,282 rhts_task task_exited: INFO task_exited([Failure instance: Traceback (failure with no frames): <class 'twisted.internet.error.ProcessTerminated'>: A process has ended with a probable error condition: process ended with exit code 143.\n])\n"}]


Version-Release number of selected component (if applicable):
 rhts-test-env-4.70-1.el7_2.noarch

How reproducible:
 Seemingly every time

Steps to Reproduce:
1. Reserve a system in Beaker
2. Extend the reservation
3. Wait some additional time, though much less than the reservation

Actual results:
 The task aborts

Expected results:
 The reservation is extended by the value indicated

Additional info:
 Full example logs: http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2016/06/13648/1364872/2783683/41881383/debug/.task_beah_raw

Comment 1 Roman Joost 2016-06-16 00:49:47 UTC
Dear Kyle,

it seems you hit the problem we've finally fixed for Beaker 23 in Bug 1284368 (not released yet). You tried to reserve for 7 days, but the limit is actually 99 hours (4 days). The task was aborted by the normal timeout, missing an additional extendtesttime. I'm speculating here a bit, since all we can look at is the beah_raw log.

It's actually harder to find the real cause here, since you've only attached the beah_raw log. I've dug out the actual job you ran: https://beaker.engineering.redhat.com/jobs/1364872 (correct me if I'm wrong) and the machine does not provide a console log, which would help checking if you actually ran the extendtesttime.sh script before the task hit the 99hours timeout.

So all in all I think not a bug. Let me know if there is anything else to it, otherwise I'll close this.


Note You need to log in before you can comment on or make changes to this bug.