Bug 1346368 - man rhsm.conf is missing a description for the server_timeout configuration
Summary: man rhsm.conf is missing a description for the server_timeout configuration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Kevin Howell
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: 1395274
TreeView+ depends on / blocked
 
Reported: 2016-06-14 15:50 UTC by John Sefler
Modified: 2020-05-14 15:12 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:18:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1488 None closed 1346368: Add server_timeout to rhsm.conf manpage 2020-07-06 07:38:25 UTC
Red Hat Bugzilla 1346417 None CLOSED [RFE] Allow users to set socket timeout. 2019-11-05 23:06:26 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Internal Links: 1346417

Description John Sefler 2016-06-14 15:50:39 UTC
Description of problem:
Recently introduced by the following python-rhsm commit is a new/optional configuration for [server] server_timeout that should be described in the man page for rhsm.conf provided by the subscription-manager package.

    Commit: 5780140650a59d45a03372a0390f92fd7c3301eb
    Allow users to set socket timeout.
    Remove the old method of setting a universal timeout (which was required 
    due to limitations in Python versions that we don't support any more) 
    and instead specify the timeout on a per-connection basis.

You will now see it as an available configuration in...

[root@jsefler-rhel7 ~]# subscription-manager config
[server]
   hostname = jsefler-candlepin.usersys.redhat.com
   insecure = [0]
   port = 8443
   prefix = /candlepin
   proxy_hostname = []
   proxy_password = []
   proxy_port = []
   proxy_user = []
   server_timeout = [180]          <========== NEW CONFIG
   ssl_verify_depth = [3]

[rhsm]
   baseurl = [https://cdn.redhat.com]
   ca_cert_dir = [/etc/rhsm/ca/]
   consumercertdir = [/etc/pki/consumer]
   entitlementcertdir = [/etc/pki/entitlement]
   full_refresh_on_yum = [0]
   manage_repos = [1]
   pluginconfdir = [/etc/rhsm/pluginconf.d]
   plugindir = [/usr/share/rhsm-plugins]
   productcertdir = [/etc/pki/product]
   repo_ca_cert = /etc/rhsm/ca/redhat-uep.pem
   report_package_profile = [1]

[rhsmcertd]
   autoattachinterval = [1440]
   certcheckinterval = [240]

[] - Default value in use



Version-Release number of selected component (if applicable):
[root@jsefler-rhel7 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 2.0.13-1
subscription management rules: 5.20
subscription-manager: 1.17.7-1.git.5.9187cce.el7
python-rhsm: 1.17.3-0.git.10.a0557db.el7


How reproducible:


Steps to Reproduce:
1. man rhsm.conf

Actual results:


Expected results:
  The man page for rhsm.conf should include a description for the new option server_timeout under the section for [SERVER] OPTIONS.

Additional info:

Comment 2 Philipp Gassmann 2017-02-07 14:43:21 UTC
When will the updated documentation land in RHEL?

Comment 5 Rehana 2017-04-03 05:00:35 UTC
Retested on :

subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.4-1.el7
python-rhsm: 1.19.2-1.el7


Observed that now "server_timeout" option is listed under the [SERVER] OPTIONS section.

#man rhsm.conf 

RHSM.CONF(5)                                                                                                                                                                                     RHSM.CONF(5)

NAME
       rhsm.conf - Configuration file for the subscription-manager tooling

DESCRIPTION
       The rhsm.conf file is the configuration file for various subscription manager tooling. This includes subscription-manager, subscription-manager-gui, rhsmcertd, and virt-who.

[SERVER] OPTIONS
  <snip>
       server_timeout
           Set this to a non-blank value to override the HTTP timeout in seconds. The default is 180 seconds (3 minutes).

Marking as verified!!

Comment 6 errata-xmlrpc 2017-08-01 19:18:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.