Bug 1346380 - RFE Port krop to python3
RFE Port krop to python3
Status: CLOSED DUPLICATE of bug 1370721
Product: Fedora
Classification: Fedora
Component: krop (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-14 12:17 EDT by Raphael Groner
Modified: 2016-08-28 15:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-28 15:37:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raphael Groner 2016-06-14 12:17:21 EDT
Description of problem:
According to the Python packaging guidelines [0], software must be
packaged for Python 3 if upstream supports it.
The guidelines give detailed information on how to do this, and even
provide an example spec file [1].

The current best practice is to provide subpackages for the two Python
versions (called "Common SRPM" in the guidelines). Alternatively, if
nothing depends on your Python2 package, you can just switch to Python 3
entirely.

It's OK to do this in Rawhide only, however, it would be greatly
appreciated if you could push it to Fedora 24 as well.


If you need more instructions, a guide for porting Python-based RPMs is
available at [2].
If anything is unclear, or if you need any kind of assistance with the
porting, you can ask on IRC (#fedora-python on Freenode), or reply here.
We'll be happy to help!


[0] https://fedoraproject.org/wiki/Packaging:Python
[1] https://fedoraproject.org/wiki/Packaging:Python#Example_common_spec_file
[2] http://python-rpm-porting.readthedocs.io/


Version-Release number of selected component (if applicable):
rawhide

How reproducible:
-

Steps to Reproduce:
1. dnf install krop
2.
3.

Actual results:
python2 is needed as runtime dependency.

Expected results:
No dependency to python2 packages, instead python3 is used for execution without any syntax errors while runtime.

Additional info:
See the thread ¹ about krop and python3 on the python mailing list. We reverted to python2 cause upstream sources are not compatible (yet) with python3 and a simple run of modernize (or 2to3 tool) only is not sufficient to make the code work in production.
¹ https://lists.fedoraproject.org/archives/list/python-devel@lists.fedoraproject.org/message/KX2PKVEC43OA5ZEVPZIJRV7VYJJAPYCC/
Comment 1 Raphael Groner 2016-08-28 15:37:55 EDT

*** This bug has been marked as a duplicate of bug 1370721 ***

Note You need to log in before you can comment on or make changes to this bug.