Bug 13464 - 3c509 not working
3c509 not working
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-04 06:59 EDT by kparker65
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 19:11:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kparker65 2000-07-04 06:59:01 EDT
When installing redhat, the 3c509 card is not detected. I have used netconf 
and linuxconf to configure the card via static and dhcp. The card does not 
initialize (delaying eth0 initializitian). There are 0 conflicts with the 
card and the address does not seem to matter. When I was able to force the 
init of the card prior to a reinstall, I could send packets out and not 
recieve any (even during dhcp). This seemed to be a problem in previous 
versions and there is no resolution listed. The card works just fine in 
Windows and I have tried PNP enabled and disabled.
Comment 1 Nalin Dahyabhai 2000-07-06 09:31:11 EDT
Kernel issue?
Comment 2 kparker65 2000-07-06 16:03:45 EDT
This does not seem to be a kernel issue. The kernel is configured for network 
support out of the box and I have tried new kernels. Network and 3c509 support 
are enabled. There is no error message upon loading the driver, it finds the 
card no matter what address I put it on. I believe that the driver is bad and 
3COM needs to create one that works.
Comment 3 Alan Cox 2000-09-16 17:48:36 EDT
The 3c509 driver works for everyone else I know of on the planet. 

Set the card to an IRQ, and I/O that are definitely free with the config
program. Make sure that
IRQ is marked as 'ISA/Legacy' in the BIOS and let me know if it helps

After loading the module see what 'dmesg' says.

Comment 4 Need Real Name 2000-12-06 12:55:48 EST
I've seen problems of a similiar nature on certain PCs.  When using Micron PCs
there is a BIOS bug in some models that will misallocate interrupts.  The box is
supposed to allocate PCI interrupts in a certain order.  Knowing this order 
should
allow the user to decide which interrupts are safe for use by ISA devices.
Unfortunately sometimes the BIOS decides to allocate DIFFERENT interrupts
for PCI usage thus leaving formerly working ISA gear not working.  "It worked
perfectly before, I have no idea what happened!" - sound familiar ?
I'm not saying this is the problem in this case but I assure you this is a very
real thing.  The Microns I've seen this one use AMI BIOSes and I think it
would be reasonable to wonder if other motherboards which use AMI BIOSes
have the same or similiar problems.

You might try catting /proc/pci and checking to see what it says about
resource allocation.

Note You need to log in before you can comment on or make changes to this bug.