Bug 134642 - Multi session CD writing produces unreadable disks
Summary: Multi session CD writing produces unreadable disks
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: k3b   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-05 12:22 UTC by Ralf Ertzinger
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-20 16:29:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
k3b log of multisession write (4.53 KB, text/plain)
2004-10-05 12:43 UTC, Ralf Ertzinger
no flags Details

Description Ralf Ertzinger 2004-10-05 12:22:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041002
Firefox/0.10.1

Description of problem:
When writing a data cd in multisession mode (default in k3b is single
session), the resulting CD is not readable.


Attempts to mount the disk result in multiple kernel messages along
the lines of

hdc: command error: status=0x51 { DriveReady SeekComplete Error }
hdc: command error: error=0x54
ide: failed opcode was 100
end_request: I/O error, dev hdc, sector 0
Buffer I/O error on device hdc, logical block 0

Writing a multi session CD from the command line seems to work fine,
though.

Version-Release number of selected component (if applicable):
k3b-0.11.14-1

How reproducible:
Always

Steps to Reproduce:
1. write a multi session cd
2. try to mount
3.
    

Actual Results:  Burn process completes successfully, cd is unreadable

Expected Results:  Readable CD

Additional info:

Comment 1 Harald Hoyer 2004-10-05 12:35:03 UTC
could you attach a k3b log?

Comment 2 Ralf Ertzinger 2004-10-05 12:43:34 UTC
Created attachment 104778 [details]
k3b log of multisession write

Comment 3 Harald Hoyer 2004-10-05 13:25:51 UTC
ok... this is the -xa1 options k3b seems to use...

Comment 4 Ralf Ertzinger 2004-10-05 13:43:43 UTC
Might be, my command line scripts do not use it (and produce usable
disks). So this is a cdrecord bug after all.

Comment 5 drago01 2004-10-10 10:30:22 UTC
I have the same problems. should this bug be reported against cdrecord?

Comment 6 Ralf Ertzinger 2004-10-10 10:47:43 UTC
I'm moving this to cdrtools.

Comment 7 Harald Hoyer 2004-10-11 08:47:08 UTC
no no... this is k3b... not cdrtools. It adds -xa1 to the command
line. I will make an erratum today.

Comment 8 Ralf Ertzinger 2004-10-11 17:00:49 UTC
Is this because k3b suddenly used this parameter (although it should
not), or does k3b fail to provide the additional data needed for this
mode (although it should)?

Comment 9 Harald Hoyer 2004-10-13 13:49:00 UTC
should be fixed with k3b-0.11.14-2

Comment 10 Michael Schwendt 2004-10-15 14:09:06 UTC
A question related to the added patch:

Should the cdrecord "dvd-patch" feature flag in k3b be used elsewhere
in the code? The only place where it is evaluated is in
src/projects/k3bdvdrecordwriter.cpp and is commented out. dvdrecord is
hardcoded there.

Comment 11 Harald Hoyer 2004-10-15 14:20:10 UTC
yes, sure the dvd-patch feature is set and then the version string is
stripped of "-dvd", because otherwise the version comparisons think we
have an old version of cdrecord. but the "dvd-patch" feature is set
and we are safe...
I changed nothing, than bugfix the version comparisons....

Comment 12 Michael Schwendt 2004-10-15 14:28:16 UTC
Indeed. And dvdrecord just executes cdrecord on fc2.

Comment 13 Harald Hoyer 2004-10-15 14:32:27 UTC
dvdrecord is not used... if cdrecord has the dvd-patch feature


Note You need to log in before you can comment on or make changes to this bug.