Bug 134643 - Nautilus will not start, giving error "The application nautilus-audio-viewer has quit unexpectedly"
Nautilus will not start, giving error "The application nautilus-audio-viewer ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus-media (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-10-05 08:24 EDT by Xander D Harkness
Modified: 2016-06-07 18:45 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.8.1-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 19:33:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xander D Harkness 2004-10-05 08:24:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040930

Description of problem:
The nautilus file manager will not start giving the error:
"The application nautilus-audio-viewer has quit unexpectedly"

I can see the following processes running afterwards:
nautilus, gnome-vfs-daemon, mapping-daemon, nautilus-throbb

however nautilus does not appear.

Version-Release number of selected component (if applicable):
nautilus-media-0.8.1-1

How reproducible:
Always

Steps to Reproduce:
1.Click on file manager on the menu in gnome or in KDE start nautilus
--no-desktop
2.Nautilus will not appear, though it will start a nautilus process.
3.
    

Actual Results:  Nautilus did not appear and does not work.
It seems that the default for my home directory was audio view.  I
tried nautilus --no-desktop /tmp and it works, changing to my home
directory and nautilus-media-view crashes.  On the console I get the
following output:
nautilus --browser --no-desktop
looking for type: got text/plain
looking for type: got text/plain
looking for type: got application/x-gnome-app-info
looking for type: got text/plain
looking for type: got text/plain
looking for type: got audio/vnd.rn-realaudio
looking for type: got application/msword

** (nautilus:4847): WARNING **: A view failed. The UI will handle this
with a dialog but this should be debugged.

** (nautilus:4847): CRITICAL **: file nautilus-view-frame.c: line 1176
(nautilus_view_frame_get_first_visible_file): assertion
`NAUTILUS_IS_VIEW_FRAME (view)' failed

--- Hash table keys for warning below:
--> file:///home

(nautilus:4847): Eel-WARNING **: "nautilus-metafile.c: metafiles" hash
table still has 1 element at quit time (keys above)

--- Hash table keys for warning below:
--> file:///home

(nautilus:4847): Eel-WARNING **: "nautilus-directory.c: directories"
hash table still has 1 element at quit time (keys above)

(nautilus:4847): Bonobo-WARNING **: Leaked a total of 3 refs to 3
bonobo object(s)

Expected Results:  Nautilus should have started by default in icon
view as was used previously and should not crash, when switching to
audio view

Additional info:
Comment 1 Colin Walters 2004-10-06 10:43:29 EDT
Can you narrow the problem down to a particular file?

Comment 2 Xander D Harkness 2004-10-07 20:10:47 EDT
I have narrowed it down to one particular wav file.
Comment 3 Alexander Larsson 2004-10-08 10:02:18 EDT
Can you attach it?
Comment 4 Mike Lurk 2004-10-10 14:49:28 EDT
I have the same problem. This is one way to get around it for now.
Uninstall nautilus-media and kill the process for nautilus and it
should start. The next thing I am going to try is to install the
pevious version of nautilus media to see if it causes the same problem.
Comment 5 Mike Lurk 2004-10-10 15:52:07 EDT
I think I have found out what the problem is. I did some playing
around with the prefs for nautilus and this is what I found out. 

With nautilus-media 0.8.1-1 installed and there is an audio file in
your $Home folder it tries to play the audio file when starting nautilus. 

This is what I had to do to fix it. 
1. Uninstall nautilus-media.
2. Kill the process for nautilus.
3. Move all audio files to another folder
4. Start nautilus and in prefs>preview>sound files>preview sound files
set it to never.
5. reinstall nautilus-media
now nautilus should work fine.

When you set nautilus to view as Audio and try to play them it
doesn't, seems that the audio player in nautilus does not play audio
files as of yet, or rythmbox is not set to play audio files. I get an
error when trying to play them; Error no information yet.



Comment 6 Colin Walters 2004-10-14 13:01:17 EDT
I can reproduce with this file, investigating now.
Comment 7 Colin Walters 2004-10-14 19:33:28 EDT
I worked around this for now by simply disabling support for wav
files.  That's certainly less than desirable but it's probably the
best thing to do for FC3.  Once I get a chance I'll debug and try to
get an FC3 update out.

Note You need to log in before you can comment on or make changes to this bug.