Bug 134650 - Uninstallation inconsistence (read-only filesystem)
Summary: Uninstallation inconsistence (read-only filesystem)
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: 2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-05 13:26 UTC by Lukas Jelinek
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 13:51:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lukas Jelinek 2004-10-05 13:26:15 UTC
From Bugzilla Helper:
User-Agent: Opera/7.50 (Windows NT 5.1; U)  [en]

Description of problem:
Situation description: /usr mounted read-only, other mount points 
mounted read/write, some package (e.g. mypkg.rpm) installed 
(somewhere in /usr/...).

If I try to uninstall mypkg.rpm (rpm -e mypkg.rpm), it finishes 
"successfully" (the package appears to be erased, rpm -q mypkg.rpm 
reports "not installed"), but package's files of course persist on 
the disk (mounted read-only).
I think this behavior is a bug. If the files cannot be removed, the 
uninstallation process should fail.


Version-Release number of selected component (if applicable):
rpm-4.3.1-0.3

How reproducible:
Always

Steps to Reproduce:
1. Have /usr on a separate filesystem mounted read/write.
2. Install a RPM package which installs its files under /usr.
3. Mount /usr as read-only (e.g. mount -o remount,ro /usr).
4. Try to uninstall this package.
    

Actual Results:  1. The "uninstalled" package appears to be erased.
2. Package's files are at their places under /usr.

Expected Results:  Uninstall will fail, reporting something like 
"Uninstall failed - cannot remove files placed on read-only 
filesystem".

Additional info:

Comment 1 Jeff Johnson 2004-10-05 13:51:06 UTC
rpm does "best effort" erasure, attempts, prints erro
in debugging spew, then continues.

"best effort" is the better approach because install/upgrade
are what people mostly use rpm for, not pure erasures.


Note You need to log in before you can comment on or make changes to this bug.