Bug 134655 - pam_env requires /etc/environment to exist
Summary: pam_env requires /etc/environment to exist
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pam   
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tomas Mraz
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 133564 (view as bug list)
Depends On:
Blocks: 134551
TreeView+ depends on / blocked
 
Reported: 2004-10-05 13:55 UTC by David Juran
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-06 03:51:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Juran 2004-10-05 13:55:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040803

Description of problem:
pam_env, which is by default called from system_auth, requires the
file /etc/environment to exist. This file however is not part of the
distribution. Therefor it is e.g. not possible to do rsh to the system.

Version-Release number of selected component (if applicable):
pam-0.77-56

How reproducible:
Always

Steps to Reproduce:
1. rsh ams
Critical error - immediate abort
rlogin: connection closed.


Additional info:

Comment 1 Suzanne Hillman 2004-10-05 18:16:12 UTC
Can you give a bit more information on how you determined that
/etc/enviroment was needed by pam_env? Does this show up as an error
when it tried to run?

Comment 2 David Juran 2004-10-05 18:54:55 UTC
A quick look in the sourcecode for pam gave me the hint that this was
the case. And then
touch /etc/environment
remedied the problem (-:

Comment 4 Bill Nottingham 2004-10-06 03:51:20 UTC
This is fixed in current setup packages.

Comment 6 Tomas Mraz 2004-10-08 07:53:48 UTC
*** Bug 133564 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.