Bug 134674 - pam_ccreds should BuildRequires: openssl-devel automake16
pam_ccreds should BuildRequires: openssl-devel automake16
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pam_ccreds (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
: EasyFix
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-10-05 11:35 EDT by Maxim Dziumanenko
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-09 10:50:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New spec file (1.88 KB, text/plain)
2005-02-04 16:40 EST, Rudi Chiarito
no flags Details

  None (edit)
Description Maxim Dziumanenko 2004-10-05 11:35:01 EDT
Description of problem:
openssl headers needed to build pam_ccreds.
And build fails if automake16 is missing.

Version-Release number of selected component (if applicable):
pam_ccreds-1-2

How reproducible:
Always

Steps to Reproduce:
1.rpm -e openssl-devel automake16
2.rpmbuild -ba pam_ccreds-1-2.src.rpm
3.Wait for build error
  
Actual results:


Expected results:


Additional info:
Comment 1 Miloslav Trmač 2004-10-12 18:34:50 EDT
Fixedin pam_ccreds-1-3. Thanks for your report.
Comment 2 Rudi Chiarito 2005-02-04 16:16:14 EST
I think the fix is wrong. A dependency was added for openssl, while it
probably should have been openssl-devel instead.
Comment 3 Rudi Chiarito 2005-02-04 16:40:16 EST
Created attachment 110677 [details]
New spec file

This spec file fixes the buildrequires for openssl to openssl-devel. It also
fixes bug #142623
Comment 4 Rudi Chiarito 2005-06-02 11:31:31 EDT
Is it too late for this to be fixed in FC4? My spec file also includes the doc
files (README and the precious pam.conf). I can't seem able to reopen this bug.
Comment 5 John Dennis 2005-06-06 19:21:12 EDT
Unfortunately it is too late for FC4, that release is frozen. I will however
make the fix in CVS which will make it available for rawhide and FC5. I am
reopening the bug report.
Comment 6 John Dennis 2005-06-09 10:50:58 EDT
fixed in pam_ccreds-1.7

Note You need to log in before you can comment on or make changes to this bug.