Bug 1346812 - Useless additional repos enabled on MON and OSD nodes
Summary: Useless additional repos enabled on MON and OSD nodes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-ansible
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Alfredo Deza
QA Contact: Daniel Horák
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-15 11:43 UTC by Daniel Horák
Modified: 2016-08-23 19:55 UTC (History)
10 users (show)

Fixed In Version: ceph-ansible-1.0.5-21.el7scon
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:55:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Daniel Horák 2016-06-15 11:43:43 UTC
Description of problem:
  I've checked list of enabled repos on Ceph cluster configured via USM and I'm slightly surprised why there are enabled repos following (unnecessary?) repos:
  On MON node:
    ~~~~~~~~~~~~~~~~~~
    rhel-7-server-optional-rpms
    rhel-7-server-rhceph-1.3-mon-rpms
    ~~~~~~~~~~~~~~~~~~
  On OSD node:
    ~~~~~~~~~~~~~~~~~~
    rhel-7-server-optional-rpms
    rhel-7-server-rhceph-1.3-osd-rpms
    ~~~~~~~~~~~~~~~~~~

Version-Release number of selected component (if applicable):
USM Server:
  ceph-ansible-1.0.5-19.el7scon.noarch
  ceph-installer-1.0.11-1.el7scon.noarch
  rhscon-ceph-0.0.20-1.el7scon.x86_64
  rhscon-core-0.0.21-1.el7scon.x86_64
  rhscon-ui-0.0.34-1.el7scon.noarch
  
MON node:
  calamari-server-1.4.1-1.el7cp.x86_64
  ceph-base-10.2.2-1.el7cp.x86_64
  ceph-common-10.2.2-1.el7cp.x86_64
  ceph-mon-10.2.2-1.el7cp.x86_64
  ceph-selinux-10.2.2-1.el7cp.x86_64
  libcephfs1-10.2.2-1.el7cp.x86_64
  python-cephfs-10.2.2-1.el7cp.x86_64
  rhscon-agent-0.0.9-1.el7scon.noarch
  
OSD Node:
  ceph-base-10.2.2-1.el7cp.x86_64
  ceph-common-10.2.2-1.el7cp.x86_64
  ceph-osd-10.2.2-1.el7cp.x86_64
  ceph-selinux-10.2.2-1.el7cp.x86_64
  libcephfs1-10.2.2-1.el7cp.x86_64
  python-cephfs-10.2.2-1.el7cp.x86_64
  rhscon-agent-0.0.9-1.el7scon.noarch


How reproducible:
  100%

Steps to Reproduce:
1. Prepare nodes for USM Cluster.
2. Install Ceph 2.0 cluster via USM web UI
3. List enabled repos on the storage nodes.
  # yum repolist

Actual results:
  Except the expected repos there are also following repos:
  On MON node:
    ~~~~~~~~~~~~~~~~~~
    rhel-7-server-optional-rpms
    rhel-7-server-rhceph-1.3-mon-rpms
    ~~~~~~~~~~~~~~~~~~
  On OSD node:
    ~~~~~~~~~~~~~~~~~~
    rhel-7-server-optional-rpms
    rhel-7-server-rhceph-1.3-osd-rpms
    ~~~~~~~~~~~~~~~~~~

Expected results:
  For Ceph 2.0 there shouldn't be rhceph-1.3 repos.
  Why there is optional repo enabled?

Additional info:

Comment 1 Ken Dreyer (Red Hat) 2016-06-16 02:46:04 UTC
Alfredo, is something in ceph-ansible enabling these repos in subscription-manager?

rhel-7-server-optional-rpms should not be enabled at all

"1.3" should be "2"

Comment 6 Alfredo Deza 2016-06-16 14:22:32 UTC
Pull request opened: https://github.com/ceph/ceph-ansible/pull/851

Comment 8 Christina Meno 2016-06-17 21:39:36 UTC
https://github.com/ceph/ceph-ansible/pull/851/files

Comment 14 Daniel Horák 2016-07-29 09:43:01 UTC
Tested on RHEL 7.2:
  ceph-ansible-1.0.5-31.el7scon.noarch
  ceph-installer-1.0.14-1.el7scon.noarch
  rhscon-ceph-0.0.38-1.el7scon.x86_64
  rhscon-core-0.0.38-1.el7scon.x86_64
  rhscon-core-selinux-0.0.38-1.el7scon.noarch
  rhscon-ui-0.0.51-1.el7scon.noarch

Only proper/excepted repos are enabled on Ceph MON and OSD nodes.

Ceph MON node:
  rhel-7-server-rhceph-2-mon-rpms
Ceph OSD node:
  rhel-7-server-rhceph-2-osd-rpms

>> VERIFIED

Comment 16 errata-xmlrpc 2016-08-23 19:55:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.