Bug 1346897 - Failure to attach NFS storage
Summary: Failure to attach NFS storage
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 3.6.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-3.6.8
: ---
Assignee: Maor
QA Contact: Aharon Canan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-15 15:18 UTC by Rafael Martins
Modified: 2016-06-15 16:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-15 16:25:24 UTC
oVirt Team: Storage
amureini: ovirt-3.6.z?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
vdsm.log (269.80 KB, text/plain)
2016-06-15 15:18 UTC, Rafael Martins
no flags Details
engine.log (350.01 KB, text/plain)
2016-06-15 15:18 UTC, Rafael Martins
no flags Details

Description Rafael Martins 2016-06-15 15:18:05 UTC
Created attachment 1168419 [details]
vdsm.log

Description of problem: While trying to setup new ovirt-engine (Centos 7, 3.6.7.4-1), after adding a new host (Centos 7), got some errors when adding NFS storage, that is a directory shared from ovirt-engine machine. Logs attached.


Version-Release number of selected component (if applicable): ovirt-engine-3.6.7.4-1


How reproducible:


Steps to Reproduce:
1. install ovirt-engine-3.6.7.4-1 on fresh CentOS 7 machine.
2. add host (another fresh CentOS 7 machine)
3. create nfs-shared directory on engine machine
4. try to add nfs storage to engine. 

Actual results:
Error while trying to mount nfs storage

Expected results:
New storage attached to host, and datacenter up

Additional info: More logs can be provided on request

Comment 1 Rafael Martins 2016-06-15 15:18:47 UTC
Created attachment 1168420 [details]
engine.log

Comment 2 Maor 2016-06-15 15:24:13 UTC
It looks like you encounter a problem to mount the storage domain.
Can u please try to mount the storage domain manually from the Host server

Comment 3 Allon Mureinik 2016-06-15 15:34:59 UTC
Relevant part of the log:

Traceback (most recent call last):
  File "/usr/share/vdsm/storage/hsm.py", line 2470, in connectStorageServer
    conObj.connect()
  File "/usr/share/vdsm/storage/storageServer.py", line 455, in connect
    return self._mountCon.connect()
  File "/usr/share/vdsm/storage/storageServer.py", line 237, in connect
    six.reraise(t, v, tb)
  File "/usr/share/vdsm/storage/storageServer.py", line 229, in connect
    self._mount.mount(self.options, self._vfsType, cgroup=self.CGROUP)
  File "/usr/share/vdsm/storage/mount.py", line 225, in mount
    return self._runcmd(cmd, timeout)
  File "/usr/share/vdsm/storage/mount.py", line 241, in _runcmd
    raise MountError(rc, ";".join((out, err)))
MountError: (32, ';mount.nfs: Connection timed out\n')

Comment 4 Red Hat Bugzilla Rules Engine 2016-06-15 15:35:06 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 5 Rafael Martins 2016-06-15 15:38:12 UTC
(In reply to Maor from comment #2)
> It looks like you encounter a problem to mount the storage domain.
> Can u please try to mount the storage domain manually from the Host server

I tried it, and it fails with the same error. Seems to be an environment issue. I'm investigating to make sure it is not engine-related in any way, but don't seems to be.

Comment 6 Rafael Martins 2016-06-15 16:25:24 UTC
Got it working, the NFS daemons in the engine machine were in bad state. Feel free to close


Note You need to log in before you can comment on or make changes to this bug.