Bug 1346900 - some cluster related directories are mislabeled because of a missing type_transition rule
Summary: some cluster related directories are mislabeled because of a missing type_tra...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-15 15:25 UTC by Milos Malik
Modified: 2016-11-04 02:32 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-3.13.1-84.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 02:32:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2283 0 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2016-11-03 13:36:25 UTC

Description Milos Malik 2016-06-15 15:25:46 UTC
Description of problem:
# sesearch -s cluster_t -t var_run_t -T
Found 3 semantic te rules:
   type_transition cluster_t var_run_t : file cluster_var_run_t; 
   type_transition cluster_t var_run_t : sock_file cluster_var_run_t; 
   type_transition cluster_t var_run_t : fifo_file cluster_var_run_t; 

Similar rule for directories is missing.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.13.1-79.el7.noarch
selinux-policy-3.13.1-79.el7.noarch

How reproducible:
 * very often on machines configured for use in cluster

Steps to Reproduce:
 * don't know yet

Actual results:
# restorecon -Rv /run
restorecon reset /run/heartbeat context system_u:object_r:var_run_t:s0->system_u:object_r:cluster_var_run_t:s0
restorecon reset /run/heartbeat/rsctmp context system_u:object_r:var_run_t:s0->system_u:object_r:cluster_var_run_t:s0
restorecon reset /run/crm context system_u:object_r:var_run_t:s0->system_u:object_r:cluster_var_run_t:s0
#

Comment 1 Milos Malik 2016-06-15 15:29:19 UTC
# rpm -qf /run/heartbeat/
file /run/heartbeat is not owned by any package
# rpm -qf /run/crm/
file /run/crm is not owned by any package
# ls -dZ /run/heartbeat/
drwxr-x--x. root root system_u:object_r:cluster_var_run_t:s0 /run/heartbeat/
# ls -dZ /run/heartbeat/rsctmp/
drwxr-x--x. root root system_u:object_r:cluster_var_run_t:s0 /run/heartbeat/rsctmp/
# ls -dZ /run/crm/
drwxr-x---. hacluster haclient system_u:object_r:cluster_var_run_t:s0 /run/crm/
#

Comment 6 errata-xmlrpc 2016-11-04 02:32:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2283.html


Note You need to log in before you can comment on or make changes to this bug.