Bug 134694 - glibc double free or corruption 0x08737e80 - samba
Summary: glibc double free or corruption 0x08737e80 - samba
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jay Fenlason
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: FC3Target FC4Target
TreeView+ depends on / blocked
 
Reported: 2004-10-05 16:50 UTC by Tim Lank
Modified: 2014-08-31 23:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-01-15 19:55:06 UTC


Attachments (Terms of Use)
smb.conf from my box (938 bytes, text/plain)
2004-10-12 15:14 UTC, Tim Lank
no flags Details

Description Tim Lank 2004-10-05 16:50:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Red Hat Enterprise Linux RC1 with included Samba. 
 
When I try and run a net ads changetrustpw command I get . Seems like 
a low level compatibility problem with glibc and 
Samba.  Please advise. 
 
*** glibc detected *** double free or corruption:  0x08737e80 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.try and run a net ads changetrustpw command 
*** glibc detected *** double free or corruption:  0x08737e80 
2.
3.
    

Actual Results:  *** glibc detected *** double free or corruption:  
0x08737e80 


Expected Results:  the error should not have appeared

Additional info:

Comment 1 Jakub Jelinek 2004-10-05 16:52:17 UTC
Yeah, any application that does double free or stomps on memory
is incompatible with glibc.
This is a samba bug.

Comment 2 Jay Fenlason 2004-10-08 14:41:22 UTC
What version of the Samba rpms are you using?  If it's earlier than 
3.0.8-0.pre1, can you try running those RPMs?  I added a patch to 
those rpms that fixed an error in one of Samba's low level routines 
that caused smbtree to fail this way. 
 
Unfortunatly, I don't have a working ADS setup here at the moment, 
so "net atds changetrustpw" doesn't give me that error.  Can you 
attach a copy of your /etc/samba/smb.conf to this bug? 

Comment 3 Tim Lank 2004-10-12 15:14:12 UTC
Created attachment 105067 [details]
smb.conf from my box

This is the smb.conf from my RHEL4 beta RC1 box

Comment 4 Tim Lank 2004-10-13 12:43:18 UTC
I am informed by one of the Samba Team members that this is being 
looked at and will be addressed.

Comment 5 Jay Turner 2005-01-14 10:07:05 UTC
Any status on this?

Comment 6 Jay Fenlason 2005-01-14 14:29:25 UTC
The fix for this is in the samba-3.0.9-changetrustpw.patch patch which is 
included in samba-3.0.1-1.4E and later. 

Comment 7 Jay Turner 2005-01-15 19:55:06 UTC
Closing out then as that version is in the RC.


Note You need to log in before you can comment on or make changes to this bug.