Bug 134698 - pygtk2-devel should require gtk2-devel
pygtk2-devel should require gtk2-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pygtk2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-05 13:05 EDT by Maxim Dziumanenko
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-23 14:33:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxim Dziumanenko 2004-10-05 13:05:14 EDT
Description of problem:
/usr/include/pygtk-2.0/pygtk/pygtk.h from pygtk2-devel package
requires gtk/gtk.h which belongs to gtk2-devel package

Version-Release number of selected component (if applicable):
pygtk2-2.3.96-2

How reproducible:
Always

Steps to Reproduce:
1.rpm -i pygtk2-2.3.96-2.i386.rpm
2.rpm -e gtk2-devel
3.rpmbuild -ba libbtctl-0.4.1-2.src.rpm (which should require
pygtk2-devel package)
4.Wait for build error
  
Actual results:


Expected results:


Additional info:
Comment 1 Maxim Dziumanenko 2004-10-05 13:11:38 EDT
it should alse Require: python-devel, because of #include <Python.h>
in the same file
Comment 2 Matthew Barnes 2006-09-23 14:33:11 EDT
The current pygtk2 spec file BuildRequires both gtk2-devel and python2-devel, so
I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.