Bug 1347011 - [Heat] Unable to delete a deployment in progress: "ERROR: Stack overcloud already has an action (CREATE) in progress."
Summary: [Heat] Unable to delete a deployment in progress: "ERROR: Stack overcloud alr...
Keywords:
Status: CLOSED DUPLICATE of bug 1384667
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 11.0 (Ocata)
Assignee: Zane Bitter
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-15 19:24 UTC by Alexander Chuzhoy
Modified: 2016-10-20 13:52 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-20 13:52:08 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alexander Chuzhoy 2016-06-15 19:24:29 UTC
openstack-heat: Unable to delete a deployment in progress: "ERROR: Stack overcloud already has an action (CREATE) in progress."


Environment:
openstack-heat-api-6.0.0-4.el7ost.noarch
instack-undercloud-4.0.0-2.el7ost.noarch
openstack-heat-common-6.0.0-4.el7ost.noarch
python-heatclient-1.2.0-1.el7ost.noarch
openstack-heat-engine-6.0.0-4.el7ost.noarch
openstack-tripleo-heat-templates-2.0.0-9.el7ost.noarch

Steps to reproduce:
1. Start an overcloud deployment.
2. While the deployment is in progress atemmpt to delete the overcloud deployment with:
 openstack stack delete --yes overcloud

Result:
ERROR: Stack overcloud already has an action (CREATE) in progress

Expected result:
The deployment in progress should be deleted. The user/admin shouldn't wait until the running deployment finishes to reinstall.

Comment 3 Alexander Chuzhoy 2016-09-12 16:17:08 UTC
Environment:
openstack-heat-api-cfn-7.0.0-0.20160823082523.1106458.el7ost.noarch
openstack-heat-templates-0.0.1-0.20160822094546.1ac2823.el7ost.noarch
openstack-heat-engine-7.0.0-0.20160823082523.1106458.el7ost.noarch
instack-undercloud-5.0.0-0.20160818065636.41ef775.el7ost.noarch
openstack-heat-common-7.0.0-0.20160823082523.1106458.el7ost.noarch
openstack-heat-api-7.0.0-0.20160823082523.1106458.el7ost.noarch
openstack-tripleo-heat-templates-5.0.0-0.20160823140311.72404b.1.el7ost.noarch


was able to initiate stack deletion of a stack being created.

Comment 4 Zane Bitter 2016-10-20 13:52:08 UTC
This was due to the timeout on the stack stop message being far too low (2s). This will be fixed in OSP9 by bug 1384667, and is already fixed upstream in Newton (OSP10).

In the meantime, you can work around this by setting the config option "engine_life_check_timeout" to a larger value (e.g. 30s).

*** This bug has been marked as a duplicate of bug 1384667 ***


Note You need to log in before you can comment on or make changes to this bug.