Bug 1347024 - [RFE] Support Satellite registration using an activation key through the Cloudforms API
Summary: [RFE] Support Satellite registration using an activation key through the Clou...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API
Version: 5.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: GA
: cfme-future
Assignee: John Hardy
QA Contact: Dave Johnson
URL:
Whiteboard: rest:api
Depends On:
Blocks: 1252904 RHCS-CFME 1309718
TreeView+ depends on / blocked
 
Reported: 2016-06-15 20:10 UTC by Fabian von Feilitzsch
Modified: 2017-08-28 15:04 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-28 15:04:27 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Fabian von Feilitzsch 2016-06-15 20:10:25 UTC
1. Proposed title of this feature request  
   [RFE] Support Satellite registration using an activation key through the Cloudforms API


2. Who is the customer behind the request?  
   QCI (Quickstart Cloud Installer) team (Redhat)


3. What is the nature and description of the request?  
   We (Quickstart Cloud Installer) are trying to do an automated deploy of CFME with registration to Satellite included. Since there is no API available to register to Satellite with an activation key, this is not currently possible.

      
4. Why does the customer need this? (List the business requirements here)  
   This prevents us from doing a completely automated deployment of CFME, since the user will have to manually register the appliance to Satellite.


5. How would the customer like to achieve this? (List the functional requirements here)
   An API endpoint that allows you to give the relevant information (server name, activation key, maybe even the satellite cert (or path to the satellite cert))
 

6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  
   Easy to test as this is just a registration using activation key. If the system is registered after hitting the endpoint with valid information then it works.

      
7. Is there already an existing RFE upstream or in Red Hat Bugzilla?  
   No
   
   
8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?  
   No 
      
9. Is the sales team involved in this request and do they have any additional input?  
   No     
  
    
10. List any affected packages or components.  
    None known


11. Would the customer be able to assist in testing this functionality if implemented? 
    Yes

Comment 3 Chris Pelland 2017-08-28 15:04:27 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.