Bug 1347085 (CVE-2016-6250) - CVE-2016-6250 libarchive: Buffer overflow when writing large iso9660 containers
Summary: CVE-2016-6250 libarchive: Buffer overflow when writing large iso9660 containers
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2016-6250
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20160529,reported=2...
: 1358366 (view as bug list)
Depends On: 1352776 1353065 1353066
Blocks: 1334215
TreeView+ depends on / blocked
 
Reported: 2016-06-16 02:30 UTC by Doran Moppert
Modified: 2019-06-08 21:17 UTC (History)
5 users (show)

Fixed In Version: libarchive 3.2.1
Doc Type: Bug Fix
Doc Text:
A vulnerability was found in libarchive. An attempt to create an ISO9660 volume with 2GB or 4GB filenames could cause the application to crash.
Clone Of:
Environment:
Last Closed: 2016-10-18 04:56:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2016:1844 normal SHIPPED_LIVE Important: libarchive security update 2016-09-13 00:11:35 UTC

Description Doran Moppert 2016-06-16 02:30:03 UTC
The ISO9660 writer is subject to integer overflows when verifying the
filename size. This can lead to a crash when writing ISO9660 images with
2GB or 4GB filenames.

External references:
    https://github.com/libarchive/libarchive/files/295073/libarchiveOverflow.txt    https://github.com/libarchive/libarchive/issues/711

Upstream fix:
    https://github.com/libarchive/libarchive/commit/3014e198

Comment 2 Doran Moppert 2016-07-05 04:36:45 UTC
Created libarchive tracking bugs for this issue:

Affects: fedora-all [bug 1352776]

Comment 6 Adam Mariš 2016-07-21 13:37:45 UTC
*** Bug 1358366 has been marked as a duplicate of this bug. ***

Comment 7 Adam Mariš 2016-07-21 13:40:37 UTC
CVE request:

http://seclists.org/oss-sec/2016/q3/114

Comment 8 errata-xmlrpc 2016-09-12 20:13:07 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2016:1844 https://rhn.redhat.com/errata/RHSA-2016-1844.html


Note You need to log in before you can comment on or make changes to this bug.