Bug 134712 - readline doesn't obey 'set bell-style visible'
readline doesn't obey 'set bell-style visible'
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: termcap (Show other bugs)
4.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Petr Raszyk
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-05 13:59 EDT by Joshua Daniel Franklin
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-12 09:57:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Daniel Franklin 2004-10-05 13:59:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
The file /etc/inputrc (or another file indicated by INPUTRC) 
contains readline commands read at invocation.

I regularly add:

set bell-style visible 

Since the audible bell annoys me... as was apparently Chet's wish:

<http://lists.gnu.org/archive/html/bug-bash/2001-02/msg00023.html>

In RHEL4 beta1, the bell is still audible although 'bind -v' indicates
that readline is set correctly. Changing the command to 'set
bell-style none' correctly disables the function, but I prefer the
visible bell.

Version-Release number of selected component (if applicable):
readline-4.3-13

How reproducible:
Always

Steps to Reproduce:
1. echo 'set bell-style visible' >> /etc/inputrc
2. bind -f /etc/inputrc && bind -v # to verify
3. Tab-complete something (bTABTAB) and note audible bell

    

Actual Results:  Bell is still audible.

Expected Results:  Bell should be only visible.

Additional info:
Comment 1 Tim Waugh 2004-10-07 13:21:01 EDT
The same can be seen from running 'python' and pressing backspace. 
This must be a libtermcap or termcap problem I think.

(TERM was 'xterm' for my test -- although 'linux' works with no
problem with bell-style visible.)
Comment 2 Petr Raszyk 2006-01-12 09:57:16 EST
libtermcap does not read /etc/inputrc.
libtermcap reads /etc/termcap.
    Not each terminal/terminal-emulator is able to 
           'beep' 
        or 'flash'
        or 'beep' and 'flash'
    (this is a terminal-capability, terminal-capabilities are described
    in termcap or/and terminfo-database).

For more info launch at the command prompt: man 3 beep
(beep() is ncurses-function, libncurses reads terminfo-database).

You cannot 'add new' terminal/terminal-emualtor feature by modifying
any config-file.

Therefore it cannot be 'a bug' in libtermcap or /etc/termcap.

In other words: if your current terminal-emulator does not
                beep/flash, you cannot change this
                (you must modify terminal-emulator-source
                 and then 'add new capability' into
                 termcap/terminfo).

On the other hand, there can be a possible bug in redline-library
but this is not a bug in libtermcap/terminfo.

Note You need to log in before you can comment on or make changes to this bug.