Bug 1347125 - [SSUI] Manual refresh fails for dynamic dropdown in Cloudforms Self-Service Portal
Summary: [SSUI] Manual refresh fails for dynamic dropdown in Cloudforms Self-Service P...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.5.0
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: GA
: cfme-future
Assignee: eclarizi
QA Contact: Shveta
URL:
Whiteboard: ssui
Depends On:
Blocks: 1352013
TreeView+ depends on / blocked
 
Reported: 2016-06-16 06:31 UTC by Shane Boulden
Modified: 2017-08-21 13:10 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1352013 (view as bug list)
Environment:
Last Closed: 2017-08-21 13:07:48 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Shane Boulden 2016-06-16 06:31:36 UTC
Description of problem:
Manual refresh of service dialog elements does not work in the Cloudforms self-service portal.

Version-Release number of selected component (if applicable):
5.5.4.2.20160517154712_629f93b

How reproducible:
1. Create a Cloudforms service catalogue dialog that contains a dynamic drop-down, and a refresh button.
2. Set the entry point for the dynamic dropdown to an Automate method that updates the dialog based on some condition
3. Log-in to the Cloudforms self service portal (https://cloudforms/self_service)
4. Select the catalogue item created in (1)
5. Attempt to refresh the dropdown using the refresh button

Actual results:
The dynamic dropdown fails to update the list of values

Expected results:
The dynamic dropdown successfully updates the list of values

Additional info: 
Manually refreshing a dynamic dropdown using the refresh button was successfully tested using the full administrative UI, however failed for the self-service portal

Comment 3 eclarizi 2016-07-22 15:04:23 UTC
I can't reproduce on the latest master, dynamic drop downs update fine for me.

If you can reproduce on master, please export the dialog and the automate method and attach them here so that I can test using that.

Comment 4 Shveta 2016-07-27 05:50:30 UTC
As discussed in https://bugzilla.redhat.com/show_bug.cgi?id=1352013

Comment 5 Shane Boulden 2016-07-28 03:23:52 UTC
I've tested today, and this issue appears to be resolved for Cloudforms 4.0 in the latest errata, https://rhn.redhat.com/errata/RHBA-2016-1488.html

Specifically, this ticket: https://bugzilla.redhat.com/show_bug.cgi?id=1322023

I've separately tested on darga-2.20160711210308_ce72215 and CFME 5.6.0.13.20160624114606_13a9153, and the issue wasn't present on either.

Comment 6 Chris Pelland 2017-08-21 13:07:48 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Comment 7 Chris Pelland 2017-08-21 13:10:03 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.