Bug 1347148 - Localization strings for SSO module needs to use indexes for string substitutions to be translatable
Summary: Localization strings for SSO module needs to use indexes for string substitut...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: AAA
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ovirt-4.0.1
: 4.0.0
Assignee: Ravi Nori
QA Contact: Gonza
URL:
Whiteboard:
Depends On:
Blocks: 1323484
TreeView+ depends on / blocked
 
Reported: 2016-06-16 07:10 UTC by Martin Perina
Modified: 2016-07-19 06:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-19 06:26:20 UTC
oVirt Team: Infra
rule-engine: ovirt-4.0.z+
rule-engine: planning_ack+
mperina: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 59290 0 master MERGED aaa: Use indexes before string format 2016-06-16 07:15:37 UTC
oVirt gerrit 59297 0 ovirt-engine-4.0 MERGED aaa: Use indexes before string format 2016-06-16 08:23:49 UTC

Description Martin Perina 2016-06-16 07:10:42 UTC
Description of problem:

Currently localization strings for SSO module uses non-indexed format for string substitutions, for example:

  The request contains unsupported parameter value '%s' for parameter '%s'.

We need to add indexes for those string substitutions, because during translations to different languages the order of those substitutions may change. So the string above needs to be updated to:

  The request contains unsupported parameter value '%1$s' for parameter '%2$s'.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Gonza 2016-06-24 13:36:50 UTC
Basic sanity run on:
rhevm-4.0.0.5-0.1.el7ev.noarch

2016-06-24 16:35:24,246 ERROR [org.ovirt.engine.core.sso.servlets.InteractiveAuthServlet] (default task-21) [] Cannot authenticate user 'admin@internal': The user name or password is incorrect.

Comment 2 Sandro Bonazzola 2016-07-19 06:26:20 UTC
Since the problem described in this bug report should be
resolved in oVirt 4.0.1 released on July 19th 2016, it has been closed with a
resolution of CURRENT RELEASE.

For information on the release, and how to update to this release, follow the link below.

If the solution does not work for you, open a new bug report.

http://www.ovirt.org/release/4.0.1/


Note You need to log in before you can comment on or make changes to this bug.