Bug 1347156 - default to createrepo_c instead of createrepo
Summary: default to createrepo_c instead of createrepo
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: general   
(Show other bugs)
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 24.0
Assignee: Dan Callaghan
QA Contact: tools-bugs
URL:
Whiteboard:
Keywords: FutureFeature, Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-16 07:47 UTC by Dan Callaghan
Modified: 2017-02-21 18:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-21 18:48:51 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Callaghan 2016-06-16 07:47:54 UTC
We configured our production Beaker instance to use createrepo_c instead of createrepo a long time ago, for its much better speed and lower memory usage (bug 1002395). However the default in Beaker is still createrepo, not createrepo_c. It's been running well since then (aside from one early bug: https://github.com/rpm-software-management/createrepo_c/issues/3).

We should switch the default to createrepo_c (and also update the Requires for it).

Comment 1 Dan Callaghan 2016-09-28 03:46:53 UTC
http://gerrit.beaker-project.org/5275

Comment 2 Dan Callaghan 2016-10-05 23:57:47 UTC
This bug fix is included in beaker-server-24.0-0.git.123.c4a89ef which is currently available for download here:

https://beaker-project.org/nightlies/develop/

Comment 4 Dan Callaghan 2017-02-21 18:48:51 UTC
Beaker 24.0 has been released.


Note You need to log in before you can comment on or make changes to this bug.