Bug 1347157 - [v4] capabilities was removed
Summary: [v4] capabilities was removed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RestAPI
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.0.1
: 4.0.1.1
Assignee: Juan Hernández
QA Contact: Pavel Stehlik
URL:
Whiteboard:
: 1377332 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-16 07:52 UTC by Nelly Credi
Modified: 2016-09-20 07:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
In version 4 of the API, the top level /capabilities collection has been replaced with /clusterlevels, which contains information about the supported cluster levels (such as the available CPU types). The legal values for enumerated types, previously found in /capabilities, can now be found in /ovirt-engine/api/model.xml or /ovirt-engine/api/model.json.
Clone Of:
Environment:
Last Closed: 2016-07-19 06:24:18 UTC
oVirt Team: Infra
rule-engine: ovirt-4.0.z+
rule-engine: planning_ack+
juan.hernandez: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 59226 0 master MERGED Add cluster levels support 2016-06-16 17:42:11 UTC
oVirt gerrit 59227 0 master MERGED restapi: Add cluster levels support 2016-06-21 11:52:25 UTC
oVirt gerrit 59259 0 master MERGED restapi: Remove completely the 'capabilities' collection 2016-06-21 11:53:23 UTC
oVirt gerrit 59526 0 model_4.0 MERGED Add cluster levels support 2016-06-21 10:05:40 UTC
oVirt gerrit 59549 0 ovirt-engine-4.0 MERGED restapi: Add cluster levels support 2016-06-21 16:00:58 UTC
oVirt gerrit 59550 0 ovirt-engine-4.0 MERGED restapi: Remove completely the 'capabilities' collection 2016-06-21 16:00:43 UTC

Description Nelly Credi 2016-06-16 07:52:49 UTC
Description of problem:
capabilities have been removed in v4.
we need it

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
it is agreed with Juan to add it back under the name 'cluster_levels'
with versions under it and all the relevant information

Comment 1 Nelly Credi 2016-07-14 13:37:56 UTC
we are still missing permits, but there is a different bug for it
https://bugzilla.redhat.com/show_bug.cgi?id=1355647

Comment 2 Sandro Bonazzola 2016-07-19 06:24:18 UTC
Since the problem described in this bug report should be
resolved in oVirt 4.0.1 released on July 19th 2016, it has been closed with a
resolution of CURRENT RELEASE.

For information on the release, and how to update to this release, follow the link below.

If the solution does not work for you, open a new bug report.

http://www.ovirt.org/release/4.0.1/

Comment 3 Juan Hernández 2016-09-20 07:35:05 UTC
*** Bug 1377332 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.