Bug 1347197 - After mysql cluster startup , delete the master and slave pod will cause slave pod Crash loop back off
Summary: After mysql cluster startup , delete the master and slave pod will cause slav...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: ImageStreams
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Ben Parees
QA Contact: Wang Haoran
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-16 09:38 UTC by Wang Haoran
Modified: 2016-09-06 18:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-06 18:52:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Wang Haoran 2016-06-16 09:38:38 UTC
Description of problem:
After deploy the mysql cluster using cluster template, delete the master and slave pod will cause slave pod cannot startup

Version-Release number of selected component (if applicable):
registry.access.redhat.com/rhscl/mysql-56-rhel7
registry.access.redhat.com/openshift3/mysql-55-rhel7

How reproducible:
Aways

Steps to Reproduce:
1.Create project
2.Deploy mysql cluster
  $oc new-app -f https://raw.githubusercontent.com/openshift/mysql/master/5.5/examples/replica/mysql_replica.json
3.After cluster startup delete the slave pod
  $oc delete pod <slave_pod>
4. check the pod status
  $oc get pod

Actual results:
Slave pod cannot startup with logs:
You must either specify the following environment variables:
  MYSQL_USER (regex: '^[a-zA-Z0-9_]+$')
  MYSQL_PASSWORD (regex: '^[a-zA-Z0-9_~!@#$%^&*()-=<>,.?;:|]+$')
  MYSQL_DATABASE (regex: '^[a-zA-Z0-9_]+$')
Or the following environment variable:
  MYSQL_ROOT_PASSWORD (regex: '^[a-zA-Z0-9_~!@#$%^&*()-=<>,.?;:|]+$')
Or both.
Optional Settings:
  MYSQL_LOWER_CASE_TABLE_NAMES (default: 0)
  MYSQL_MAX_CONNECTIONS (default: 151)
  MYSQL_FT_MIN_WORD_LEN (default: 4)
  MYSQL_FT_MAX_WORD_LEN (default: 20)
  MYSQL_AIO (default: 1)
  MYSQL_KEY_BUFFER_SIZE (default: 32M or 10% of available memory)
  MYSQL_MAX_ALLOWED_PACKET (default: 200M)
  MYSQL_TABLE_OPEN_CACHE (default: 400)
  MYSQL_SORT_BUFFER_SIZE (default: 256K)
  MYSQL_READ_BUFFER_SIZE (default: 8M or 5% of available memory)
  MYSQL_INNODB_BUFFER_POOL_SIZE (default: 32M or 50% of available memory)
  MYSQL_INNODB_LOG_FILE_SIZE (default: 8M or 15% of available memory)
MYSQL_INNODB_LOG_BUFFER_SIZE (default: 8M or 15% of available memory) 

Expected results:
should startup successfully

Additional info:

Comment 1 Wang Haoran 2016-06-21 02:32:06 UTC
image under brew registry works well , feel free to move to ON_QA .

Comment 2 Martin Nagy 2016-06-21 11:29:18 UTC
Hm, just wanted to report that I can't reproduce. OK, moving to ON_QA.


Note You need to log in before you can comment on or make changes to this bug.