Bug 1347214 - 2.0: /api/v2/info displays fqdn with host shortname
Summary: 2.0: /api/v2/info displays fqdn with host shortname
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Calamari
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 2.3
Assignee: Boris Ranto
QA Contact: vidushi
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-16 10:09 UTC by Harish NV Rao
Modified: 2017-06-19 13:25 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-06-19 13:25:55 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1497 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC

Description Harish NV Rao 2016-06-16 10:09:16 UTC
Description of problem:
 /api/v2/info displays 'fqdn' with host shortname and 'hostname' with 'fqdn'. Looks like they are interchanged..


GET /api/v2/info
HTTP 200 OK
Vary: Accept
Content-Type: text/html; charset=utf-8
Allow: GET, HEAD, OPTIONS

{
    "version": "1.4.1-0 ", 
    "license": "N/A", 
    "registered": "N/A", 
    "hostname": "magna004.ceph.redhat.com", 
    "fqdn": "magna004", 
    "ipaddr": "10.8.128.4", 
    "bootstrap_url": "https://10.8.128.4:8002/bootstrap", 
    "bootstrap_rhel": "curl https://10.8.128.4:8002/bootstrap | sudo python", 
    "bootstrap_ubuntu": "wget -O - https://10.8.128.4:8002/bootstrap | sudo python"
}

[ubuntu@magna004 ~]$ sudo hostname
magna004

[ubuntu@magna004 ~]$ sudo hostname -f
magna004.ceph.redhat.com

Version-Release number of selected component (if applicable):calamari-server-1.4.1-1.el7cp.x86_64


How reproducible: always


Steps to Reproduce:
1. issue https://<mon ip>:8002/api/v2/info from browser

Actual results:
'fqdn' shows host shortname
'hostname' shows fqdn

Expected results:
show right values for fqdn and hostname

Additional info:

Comment 4 Christina Meno 2016-06-16 23:07:08 UTC
I don't believe there is impact to console as this API was broken entirely till a few days ago. This can wait to 2.1

Comment 6 Christina Meno 2017-03-31 15:55:39 UTC
Boris,

I am guessing that this is already fiex.
Would you please check and close as current release if so?

Comment 7 Ken Dreyer (Red Hat) 2017-04-25 17:46:57 UTC
Boris would you please check if this is already fixed in v1.5.5?

Comment 8 Boris Ranto 2017-04-25 18:41:17 UTC
It is just a simple bug where we mismatched fqdn/hostname in the Info class. I have tested the patch on my testing cluster and it fixed the issue for me.

Upstream PR:
https://github.com/ceph/calamari/pull/516

Comment 9 Ken Dreyer (Red Hat) 2017-04-25 22:30:31 UTC
Boris would you please tag v1.5.6 with that change and I'll build it for RHEL and Ubuntu?

Comment 15 errata-xmlrpc 2017-06-19 13:25:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.