Bug 1347347 - [RFE] [Director] Sahara Integration with OSP-d
Summary: [RFE] [Director] Sahara Integration with OSP-d
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 9.0 (Mitaka)
Hardware: All
OS: Linux
high
high
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Angus Thomas
QA Contact: Luigi Toscano
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-16 14:59 UTC by Elise Gafford
Modified: 2016-08-24 13:01 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-heat-templates-2.0.0-11.el7ost
Doc Type: Enhancement
Doc Text:
The OpenStack data processing service (sahara) is now deployable via OSP-d. The current release will deploy Sahara to all controller nodes and make it available for use. As this is the first release to include Sahara integration with OSP director, the service is minimally configurable, but also places no additional burden on the installer; Sahara will be enabled on overcloud controller nodes by default.
Clone Of:
Environment:
Last Closed: 2016-08-24 13:01:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1762 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Advisory 2016-08-24 16:59:57 UTC

Description Elise Gafford 2016-06-16 14:59:57 UTC
Description of problem:

OpenStack Sahara must be deployable via RHEL OSP-d.

This work is already dev complete and in the Mitaka release; this bug is being created to track testing efforts and permit release notes.

Dependency chain of upstream commits begins here:
https://review.openstack.org/#/c/221418/

Comment 3 Elise Gafford 2016-07-26 18:27:19 UTC
Adding doc text,

Comment 6 Luigi Toscano 2016-08-23 11:34:59 UTC
Sahara services (api, engine) are provisioned by default on the Controller. They answers to requests and basic API tests.


Verified on:
openstack-heat-api-6.0.0-8.el7ost.noarch
openstack-heat-api-cfn-6.0.0-8.el7ost.noarch
openstack-heat-common-6.0.0-8.el7ost.noarch
openstack-heat-engine-6.0.0-8.el7ost.noarch
openstack-heat-templates-0-0.3.96a0b0bgit.el7ost.noarch
openstack-puppet-modules-8.1.8-1.el7ost.noarch
openstack-tripleo-0.0.8-0.2.d81bd6dgit.el7ost.noarch
openstack-tripleo-common-2.0.0-8.el7ost.noarch
openstack-tripleo-heat-templates-2.0.0-31.el7ost.noarch
openstack-tripleo-heat-templates-liberty-2.0.0-31.el7ost.noarch
openstack-tripleo-image-elements-0.9.9-6.el7ost.noarch
openstack-tripleo-puppet-elements-2.0.0-4.el7ost.noarch
puppet-3.6.2-4.el7sat.noarch
python-tripleoclient-2.0.0-2.el7ost.noarch

openstack-sahara-4.0.1-2.el7ost.noarch
openstack-sahara-api-4.0.1-2.el7ost.noarch
openstack-sahara-common-4.0.1-2.el7ost.noarch
openstack-sahara-engine-4.0.1-2.el7ost.noarch
python-sahara-4.0.1-2.el7ost.noarch

Comment 9 errata-xmlrpc 2016-08-24 13:01:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1762.html


Note You need to log in before you can comment on or make changes to this bug.