Bug 1347365 - [RFE] Add optional parameter to "oc edit" so you can edit multiple resources at once.
Summary: [RFE] Add optional parameter to "oc edit" so you can edit multiple resources ...
Keywords:
Status: CLOSED DUPLICATE of bug 1309545
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Michail Kargakis
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-16 15:41 UTC by Javier Ramirez
Modified: 2020-12-11 12:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-24 09:45:28 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Javier Ramirez 2016-06-16 15:41:37 UTC
1. Proposed title of this feature request  
	  [RFE] Add optional parameter to "oc edit" so you can edit multiple resources at once.
      
	2. Who is the customer behind the request?  
	Account: Produban #1596976
      
	TAM customer: yes  
	SRM customer: yes  
	Strategic: yes  
      
	3. What is the nature and description of the request?  
		Before OpenShift 3.2, if you run "oc edit" against multiple resources, you were presented a list that allowed to edit them at a single shot.
	Now, the editor is open once per resource to edit and allows editing each resource one-by-one.
	While the current 3.2 behavior can be the best in a couple of situations, while the older behavior would be the best in another couple of situations.
	So we would like to have the 3.1.1 oc edit behavior back in an optional manner. For example, if I run:
	$ oc edit dc mydc1 mydc2
	I get the old behavior.
	But if i run:
	$ oc edit --list-all dc mydc1 mydc2
	I get the 3.1 oc edit behavior.
	4. Why does the customer need this? (List the business requirements here)  
	No business requirement just better usability according to customer.
	      
	5. How would the customer like to achieve this? (List the functional requirements here)  
	Have an optional parameter when using "oc edit "      

	6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  
	Just run "oc edit --$new_parameter mydc1 mydc2"  and be presented with a list that allows to edit all the resources at once.    

	7. Is there already an existing RFE upstream or in Red Hat Bugzilla?  
	  No

	8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?  
	  No
	9. Is the sales team involved in this request and do they have any additional input?  
	  No
	10. List any affected packages or components.  
	  atomic-openshift-clients
	11. Would the customer be able to assist in testing this functionality if implemented?  
	Yes

Comment 1 Xingxing Xia 2016-06-17 02:00:59 UTC
@ Javier Ramirez +1
Bug 1309545 reported the issue, its comment history shows it is fixed in upstream. Checked that the fix is not yet included in origin/ose oc.

Comment 2 Xingxing Xia 2016-06-17 02:08:24 UTC
BTW, it is better if 'editing multiple resources at once' is the default behavior (as oc 3.1 did), that is, without the need of --$new_parameter. In fact, `oc edit -h` already shows that: "You can edit multiple objects, although changes are applied one at a time"

Comment 3 Javier Ramirez 2016-06-24 09:45:28 UTC
Thanks Xingxing, after checking with the customer the rfe at Bug 1309545 is good enough, therefore closing this one.

*** This bug has been marked as a duplicate of bug 1309545 ***


Note You need to log in before you can comment on or make changes to this bug.