Bug 134737 - Games crash after xorg update - .i.e UT2004 crashed with Signal: SIGSEGV [segmentation fault]
Games crash after xorg update - .i.e UT2004 crashed with Signal: SIGSEGV [seg...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-05 16:33 EDT by Harry Carlyle
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 03:35:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harry Carlyle 2004-10-05 16:33:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
See URL for details. After most recent xorg update to 6.7.0-9, Open GL
games crash with various errors. For example Unreal Tournament gives this;

WARNING: ALC_EXT_capture is subject to change!
Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0".
Signal: SIGSEGV [segmentation fault]

During the installation of the xorg updates, there is a conflict noted
in up2date and/or yum update as follows;

Test install failed because of package conflicts:
file /usr/X11R6/lib/libGL.so.1.2 from install of
xorg-x11-Mesa-libGL-6.7.0-9 conflicts with file from
package fglrx-4.3.0-3.9.0

This is a direct conflict between the xorg updates and ATI driver
packages. Most users are having to uninstall their ATI drivers,
install the xorg updates, then reinstall the ATI drivers. It seemed to
work for some, others (like myself) not. The reason I mention it is
because I beleive this is relates to the opengl game crashing issues.
Here's some related links;

http://www.fedoraforum.org/forum/showthread.php?t=20783

http://www.fedoraforum.org/forum/showthread.php?t=23243

http://www.fedoraforum.org/forum/showthread.php?t=23071

http://forums.suselinuxsupport.de/i...t=0&#entry30323




Version-Release number of selected component (if applicable):
6.7.0-9

How reproducible:
Always

Steps to Reproduce:
1. Run up2date for xorg 6.7.0-9 updates, don't install
xorg-x11-Mesa-libGL due to conflicts with fglrx
2. Deinstall ATI drivers
3. Install xorg-x11-Mesa-libGL
4. Reinstall ATI Drivers
    

Actual Results:  Opengl games crash even though ATI drivers install
correctly and are verified as running with glxinfo.

Expected Results:  Opengl games do not crash

Additional info:
Comment 1 Harry Carlyle 2004-10-05 16:42:54 EDT
One link above is incorrect, it should be as follows. Added another
relevant link.

http://forums.suselinuxsupport.de/index.php?showtopic=5426&st=0&#entry30323

http://www.rage3d.com/board/showthread.php?p=1333227291#post1333227291



Comment 2 Mike A. Harris 2004-10-12 03:35:46 EDT
This isn't an X.Org bug.  You're using proprietary drivers which
are not installed from rpm packages, and overwrite Red Hat supplied
X server modules and libraries with proprietary versions from
the hardware vendor.  When you upgrade to a new Red Hat X release,
your proprietary modules/libs will be overwritten by rpm.  This
is normal and expected.

Any time you upgrade X.Org, you will have to reinstall the
proprietary driver again.  Alternatively, install the same
drivers from 3rd party rpm packages.

If you require assistance for any of the above suggestions, please
subscribe to X.Org or Red Hat mailing lists, where there are many
users who may be able to help you reinstall and/or reconfigure
your proprietary drivers.

Closing as "NOTABUG"

Note You need to log in before you can comment on or make changes to this bug.