Bug 1347425 - Logs filled with errors after deleting project
Summary: Logs filled with errors after deleting project
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.2.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Derek Carr
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-16 20:10 UTC by Vikas Laad
Modified: 2016-09-27 09:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:34:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
Logs from /var/log/messages (24.07 KB, text/plain)
2016-06-16 20:10 UTC, Vikas Laad
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Vikas Laad 2016-06-16 20:10:17 UTC
Created attachment 1168827 [details]
Logs from /var/log/messages

Description of problem:
Logs are filled with following errors when deleting a project

Jun 16 15:44:44 ip-172-31-8-173 atomic-openshift-master: E0616 15:44:44.369096   11084 endpoints_controller.go:443] Error updating endpoints: endpoints "dancer-example" is forbidden: Unable to create new content in namespace test1 because it is being terminated.


Version-Release number of selected component (if applicable):
openshift v3.2.1.2-1-g64665fc
kubernetes v1.2.0-36-g4a3f9c5
etcd 2.2.5
root@ip-172-31-8-173: ~ # docker version
Client:
 Version:         1.10.3
 API version:     1.22
 Package version: docker-common-1.10.3-42.el7.x86_64
 Go version:      go1.4.2
 Git commit:      02f13c2-unsupported
 Built:           Mon Jun 13 15:22:15 2016
 OS/Arch:         linux/amd64

Server:
 Version:         1.10.3
 API version:     1.22
 Package version: docker-common-1.10.3-42.el7.x86_64
 Go version:      go1.4.2
 Git commit:      02f13c2-unsupported
 Built:           Mon Jun 13 15:22:15 2016
 OS/Arch:         linux/amd64


How reproducible:
Frequently

Steps to Reproduce:
1. Create a new project
2. Create a new app using available templates (cakephp-mysql-example)
3. Delete a project

Actual results:
Logs are filled with attached errors

Expected results:
Logs should be clean.

Additional info:

Comment 3 Vikas Laad 2016-06-20 19:11:00 UTC
Does project deletion cause creation of any resource? We are not trying to create anything while deleting the project.

Comment 4 Vikas Laad 2016-06-22 18:22:48 UTC
This issue might be related to https://bugzilla.redhat.com/show_bug.cgi?id=1333393

Comment 5 Derek Carr 2016-08-12 15:43:36 UTC
Upstream logging fix:

https://github.com/kubernetes/kubernetes/pull/30510

Comment 6 Derek Carr 2016-08-15 15:07:22 UTC
Origin cherry-pick:

https://github.com/openshift/origin/pull/10415

Comment 7 Vikas Laad 2016-08-22 15:34:59 UTC
verified in following release, do not see these messages

openshift v3.3.0.23
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git

Comment 9 errata-xmlrpc 2016-09-27 09:34:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.