This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 134745 - Can't login via gdm
Can't login via gdm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-10-05 18:37 EDT by Zack Cerza
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 11:22:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zack Cerza 2004-10-05 18:37:13 EDT
(should this be filed on xinitrc, or gdm, or what?)

On login, gdm complains that the session lasted less than 10 seconds,
and respawns. The only way to login is to drop to console, telinit 3,
and startx. This affects existing as well as newly-created users,
including on a fresh install.

I've replaced my Xclients with an older one, but it still seems to be
broken...
Comment 1 Michele Schiavo 2004-10-06 10:27:16 EDT
After last update at 2004.10.06 H 12.00 UTC

I can't login with gdm

By init 3 and start startx, gnome session closed.
I try to create a new user, nothing to do in init 5 and init 3 + startx.

I have just updated selinux* and udev* coreutils*
Comment 2 Zack Cerza 2004-10-06 14:06:23 EDT
With the following packages I'm still affected.
gdm-2.6.0.5-3
xinitrc-4.0.13-1

root can login, as can other local users. Remote users other than me
can login as well. Maybe something in my ~ was munged...

Here's the contents of /tmp/xses-zcerza.dbBl8c:
/etc/X11/gdm/PreSession/Default: Registering your session with wtmp
and utmp
/etc/X11/gdm/PreSession/Default: running: /usr/bin/X11/sessreg -a -w
/var/log/wtmp -u /var/run/utmp -x "/var/gdm/:0.Xservers" -h "" -l ":0"
"zcerza"

That's it. Now here's the contents of /tmp/xses-root.JqHBrF:
/etc/X11/gdm/PreSession/Default: Registering your session with wtmp
and utmp
/etc/X11/gdm/PreSession/Default: running: /usr/bin/X11/sessreg -a -w
/var/log/wtmp -u /var/run/utmp -x "/var/gdm/:0.Xservers" -h "" -l ":0"
"root"
SESSION_MANAGER=local/my.hostname.com:/tmp/.ICE-unix/1034
looking for type: got text/plain
looking for type: got text/plain
looking for type: got application/x-gnome-app-info
/usr/lib64/python2.3/site-packages/gtk-2.0/gtk/__init__.py:90:
GtkDeprecationWarning: gtk.mainloop is deprecated, use gtk.main instead
  self.warn(message, DeprecationWarning)

Possibly a problem in sessreg?
Comment 3 Zack Cerza 2004-10-11 11:22:37 EDT
I found the problem. It was my fault. :|

Note You need to log in before you can comment on or make changes to this bug.