Bug 1347519 - [RFE] Allow integration of dynamic fields with _missing_instance
Summary: [RFE] Allow integration of dynamic fields with _missing_instance
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: GA
: cfme-future
Assignee: John Hardy
QA Contact: Milan Falešník
URL:
Whiteboard: dialog:automate
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-17 07:16 UTC by Fabien Dupont
Modified: 2017-08-28 15:04 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-28 15:04:07 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Fabien Dupont 2016-06-17 07:16:18 UTC
Description of problem:

Current implementation of dialog builder (Automate/Customization) only allows to select instances through a selector modal window, while there is a _missing_instance attribute in .missing instance that allows to point to methods without having a real instance. 

It would be interesting to be able to enter a path to an instance that doesn't exist, triggering the .missing / _missing_instance mechanism and thus reducing the number of instances in the automate tree.

An awesome implementation would allow raw path in the field and provide an button on the right of the field to open the selector modal window.


Version-Release number of selected component (if applicable): 4.1beta


How reproducible: Always


Steps to Reproduce:
1. Create a new dialog
2. Add an dynamic element in a box
3. Click on "Entry Point (NS/Cls/Inst)" field

Actual results:

A modal window opens to select an instance.

Expected results:

Nothing happens. The user can click on a button that opens the selector.

Additional info:

Comment 2 mkanoor 2016-06-17 14:24:47 UTC
This is a UI change, when we allow the user to pick an instance from the tree as an entry point. If the Automate class has a .missing instance we don't need to have an instance for the entry point, as long as the .missing has the logic to call the correct method we should be good. This allows us to reduce the number of instances in the Automate domain.

Maybe the UI should check if there is a .missing and allow the user to enter a valid instance name (no spaces and special characters) into a text box.

When displaying the tree would need some kind of a visual cue to let the user know that  its a "ghost" instance that doesn't exist but uses the .missing

Comment 3 Milan Falešník 2016-06-17 14:43:46 UTC
I was thinking about this when _missing_instance came into play and I guess there could be a scenario where it would show methods just like instances in that tree - in case it would detect that there is a .missing which has a method field with "${#_missing_instance}" exactly in it. That would be a pretty safe indication that someone is using this class as a method storage. I guess those "guesses" would have to be visually marked, something like italic or whatever.

Comment 4 Fabien Dupont 2016-06-18 09:05:53 UTC
At the moment, the user is responsible for the instance to do something. Maybe a first step would be to leave the user responsible to enter a valid path. The _missing_instance attribute can be used in many ways: trigger a relationship or a method, pass an input to a method... all that up to the user to create a valid structure.

Comment 6 Chris Pelland 2017-08-28 15:04:07 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.