Bug 1347520 - Some popover content could not be cleared
Summary: Some popover content could not be cleared
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.2.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-17 07:19 UTC by Yadan Pei
Modified: 2017-03-08 18:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: In some cases, a warning could be resolved while the tooltip describing the warning was open. Consequence: The tooltip could not be dismissed. Fix: We now properly close the tooltip when the warning disappears. Result: The open tooltip will disappear with the warning icon.
Clone Of:
Environment:
Last Closed: 2016-09-27 09:34:18 UTC
Target Upstream Version:


Attachments (Terms of Use)
EventWarningOnOverview (34.91 KB, image/png)
2016-06-17 07:20 UTC, Yadan Pei
no flags Details
WarningOnBrowsePage (29.45 KB, image/png)
2016-06-17 07:21 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Yadan Pei 2016-06-17 07:19:19 UTC
Description of problem:
Pod warning info could not be cleared when warning icon disappears. Also event warning info couldn't be cleared

Version-Release number of selected component (if applicable):
openshift v1.3.0-alpha.1-400-g5493ff6-dirty
kubernetes v1.3.0-alpha.3-599-g2746284
etcd 2.3.0+git

How reproducible:
Very Often

Steps to Reproduce:
1. Create a test pod which could trigger warning info on console
In this example, pod image yapei/test-volume:test1 could not be found
cat << EOF > pod.yaml 
{
  "kind": "Pod",
  "apiVersion":"v1",
  "metadata": {
        "name": "test-volume-instruction"
  },
  "spec": {
      "containers": [{
        "name": "test-volume-instruction",
        "image": "yapei/test-volume:test1",
        "ports": [
          {
            "containerPort": 8080
          }
        ]
      }]
  }
}
EOF
2. Login to web console, and go to Browse -> Pod page
3. When warning icon is triggered, hover the icon and warning info will be displayed
4. When warning icon disappears(maybe change to other intermediate state), the warning context is still there
5. Check event warning info

Actual results:
4. When warning icon disappears(maybe change to other intermediate state), the warning context is still there and shown on every page, there is no way to clear it
5. Event page warning info could not be cleared 

Expected results:
4. When warning icon disappears, popover context should also be cleared
5. Warning info should be cleared after mouse is moved away

Additional info:

Comment 1 Yadan Pei 2016-06-17 07:20:10 UTC
Created attachment 1168945 [details]
EventWarningOnOverview

Comment 2 Yadan Pei 2016-06-17 07:21:11 UTC
Created attachment 1168946 [details]
WarningOnBrowsePage

Comment 3 Yadan Pei 2016-06-17 07:22:13 UTC
Attachment  WarningOnBrowsePage is captured from OSE 
openshift v3.2.1.2-1-g64665fc
kubernetes v1.2.0-36-g4a3f9c5
etcd 2.2.5

Comment 5 Samuel Padgett 2016-07-20 13:15:42 UTC
Merged to origin-web-console. Fix will be available in origin after next vendor.

Comment 6 Samuel Padgett 2016-07-22 12:47:54 UTC
Fix should be in origin master now.

Comment 7 Yadan Pei 2016-07-25 02:16:03 UTC
Checked against devenv-rhel7_4656

openshift v1.3.0-alpha.2+5c862c0
kubernetes v1.3.0+57fb9ac
etcd 2.3.0+git


Now warning info on pod & event page will disappear when mouse is moved away

Move to VERIFIED

Comment 9 errata-xmlrpc 2016-09-27 09:34:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.