Bug 1347621 - RHEL 7.2 beta info is in RHEV-H-NG /etc/*-release
Summary: RHEL 7.2 beta info is in RHEV-H-NG /etc/*-release
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-release-rhev-hypervisor
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.0.2
: ---
Assignee: Fabian Deutsch
QA Contact: Ying Cui
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-17 09:14 UTC by Ying Cui
Modified: 2016-08-23 21:07 UTC (History)
11 users (show)

Fixed In Version: redhat-release-virtualization-host-4.0-0.28.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 21:07:50 UTC
oVirt Team: Node


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1702 normal SHIPPED_LIVE redhat-virtualization-host bug fix and enhancement update for RHV 4.0 2016-08-24 00:35:27 UTC

Description Ying Cui 2016-06-17 09:14:48 UTC
Description
Checking RHEV-H-NG 4.0 /etc/redhat-release, there display "Red Hat Enterprise Linux release 7.2 Beta"

How reproducible:
100%

Test steps:
1. Installed RHEV-H-NG 4.0 beta 1 iso(RHEV-H-7.2-20160616.3-RHVH-x86_64-dvd1.iso)
2. Check /etc/redhat-release

# cat /etc/redhat-release
Red Hat Enterprise Linux release 7.2 Beta

# cat /etc/os-release
NAME="Red Hat Enterprise Linux"
VERSION="7.2"
VERSION_ID="7.2"
ID="rhel"
ID_LIKE="fedora"
VARIANT="Red Hat Enterprise Virtualization Hypervisor NG"
VARIANT_ID="ovirt-node"
PRETTY_NAME="Red Hat Enterprise Virtualization Hypervisor NG 4.0"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.2:beta:hypervisorng"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

# FIXME
REDHAT_BUGZILLA_PRODUCT="Red Hat Enterprise Virtualization"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.2
REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Virtualization"
REDHAT_SUPPORT_PRODUCT_VERSION=7.2

# rpm -qa imgbased kernel
kernel-3.10.0-327.18.2.el7.x86_64
imgbased-0.7.0-0.1.el7ev.noarch

RHEV-H-7.2-20160616.3-RHVH-x86_64-dvd1.iso

Actual Result:
RHEL 7.2 beta info is in RHEV-H-NG 4.0 /etc/redhat-release

Expected Result:
Red Hat Enterprise Virtualization Hypervisor NG 7.2 Beta is in /etc/redhat-release rather than RHEL info.

Comment 1 Ying Cui 2016-07-04 04:53:08 UTC
After RHEV-H-7.2-20160701.2-RHVH-x86_64-dvd1.iso installation(using the default ks.cfg), it still display the _RHEL_ info in /etc/redhat-release, not match the bug expected result to display RHV Beta info.

# rpm -qa redhat-release-rhev-hypervisor
redhat-release-rhev-hypervisor-4.0-0.9.el7.x86_64

# cat /etc/redhat-release 
Red Hat Enterprise Linux release 7.2

Comment 2 Ryan Barry 2016-07-04 05:09:47 UTC
This is intentional. ovirt-host-deploy checks redhat-release to determine the RHEL version. Using the RHEV name/version causes a failure to add the node to engine, as rhel4 is not supported.

The RHEV version is shown in the prettyname in os-release.

Comment 3 Ying Cui 2016-07-04 08:27:59 UTC
According to comment 2, this bug need to be reconsidered.
Does it mean the users can not find out what version of RHV they are running from /etc/redhat-release file?
and this file is provided by redhat-release-rhev-hypervisor rpm, but it display with RHEL info, that will confuse the user what version are they running.

# cat /etc/redhat-release 
Red Hat Enterprise Linux release 7.2
 
# rpm -qi --whatprovides /etc/redhat-release
Name        : redhat-release-rhev-hypervisor
Version     : 4.0
Release     : 0.9.el7
Architecture: x86_64
Install Date: Sat 02 Jul 2016 03:16:40 AM CST
Group       : System Environment/Base
Size        : 10204
License     : GPLv2
Signature   : (none)
Source RPM  : redhat-release-rhev-hypervisor-4.0-0.9.el7.src.rpm
Build Date  : Sat 02 Jul 2016 12:17:24 AM CST
Build Host  : x86-024.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
Summary     : Red Hat Enterprise Virtualization Hypervisor NG release file
Description :
Red Hat Enterprise Virtualization Hypervisor NG release files

Comment 4 Ryan Barry 2016-07-04 16:08:34 UTC
That's correct -- the version cannot be determined from redhat-release. Putting the version in redhat-release (per comment#2) will break ovirt-host-deploy.

redhat-release-rhev-hypervisor probably doesn't need to own redhat-release at all anymore (we tried putting the RHEV version in redhat-release early in the 3.6 tech preview, and it caused problems, so ownership is an artifact of that).

The version is visible from rpm -q redhat-release-rhev-hypervisor, imgbase w, and (in beta 2) the cockpit dashboard.

Comment 5 Ying Cui 2016-07-07 11:36:03 UTC
Pending this bug verification, I need to think twice on this bug impact on RHVH.

Comment 6 Ying Cui 2016-08-01 10:19:40 UTC
Ryan,  currently we do not have a better solution for this bug, right? If so, I will verify this bug according to comment 4, and do not consider RHEL version info in /etc/redhat-release.

Comment 7 Ryan Barry 2016-08-01 20:49:43 UTC
(In reply to Ying Cui from comment #6)
> Ryan,  currently we do not have a better solution for this bug, right? If
> so, I will verify this bug according to comment 4, and do not consider RHEL
> version info in /etc/redhat-release.

See rhbz#1362127 for a further solution (which will also be PRETTY_NAME)

Comment 8 Ying Cui 2016-08-08 06:42:43 UTC
According to comment 7, I have to assign this bug.

In latest RHVH 4.0 build(RHVH-7.2-20160804.0-RHVH-x86_64-dvd1.iso, redhat-release-virtualization-host-4.0-0.26.el7), it is still RHEL info in /etc/redhat-release(Red Hat Enterprise Linux release 7.2), it is not PRETTY_NAME(PRETTY_NAME="Red Hat Virtualization Host 4.0 (el7.2)")

Comment 9 Fabian Deutsch 2016-08-08 12:30:12 UTC
Please paste os-release.

Please note that all fields will be == RHEL

Exception: PRETTY_NAME which will name RHVH

Comment 10 Ying Cui 2016-08-08 13:16:50 UTC
(In reply to Fabian Deutsch from comment #9)
> Please paste os-release.

# cat /etc/os-release 
NAME="Red Hat Enterprise Linux"
VERSION="7.2"
VERSION_ID="7.2"
ID="rhel"
ID_LIKE="fedora"
VARIANT="Red Hat Virtualization Host"
VARIANT_ID="ovirt-node"
PRETTY_NAME="Red Hat Virtualization Host 4.0 (el7.2)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.2:beta:hypervisor"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

# FIXME
REDHAT_BUGZILLA_PRODUCT="Red Hat Virtualization"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.2
REDHAT_SUPPORT_PRODUCT="Red Hat Virtualization"
REDHAT_SUPPORT_PRODUCT_VERSION=7.2

# cat /etc/redhat-release 
Red Hat Enterprise Linux release 7.2

> 
> Please note that all fields will be == RHEL
> 
> Exception: PRETTY_NAME which will name RHVH

PRETTY_NAME="Red Hat Virtualization Host 4.0 (el7.2)" is correct as RHVH info.

Could you check the comment 6 and comment 7, whether we can ignore the RHEL info into /etc/redhat-release?

Comment 11 Fabian Deutsch 2016-08-08 15:39:22 UTC
system-release system-release-cpe and redhat-releae and os-release all contain RHEL informations, except for the PRETTY_NAME field - and the additional VARIANT field.

The new os-release looks like:
NAME="Red Hat Enterprise Linux"
VERSION="7.2"
VERSION_ID="7.2"
ID="rhel"
ID_LIKE="fedora"
VARIANT="Red Hat Virtualization Host"
VARIANT_ID="ovirt-node"
PRETTY_NAME="Red Hat Virtualization Host 4.0 (el7.2)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.2:GA:hypervisor"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

# FIXME
REDHAT_BUGZILLA_PRODUCT="Red Hat Virtualization"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.2
REDHAT_SUPPORT_PRODUCT="Red Hat Virtualization"
REDHAT_SUPPORT_PRODUCT_VERSION=7.2

This should be correct (CPE_NAME field).

Comment 13 Ying Cui 2016-08-12 06:06:09 UTC
VERIFIED this bug according to comment 10 and comment 11.

To RHVH, we only care VARIANT and PRETTY_NAME as RHVH information.
VARIANT="Red Hat Virtualization Host"
PRETTY_NAME="Red Hat Virtualization Host 4.0 (el7.2)"

Comment 15 errata-xmlrpc 2016-08-23 21:07:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1702.html


Note You need to log in before you can comment on or make changes to this bug.