Bug 1347669 - Add /dev/urandom as entropy source for virtio-rng
Summary: Add /dev/urandom as entropy source for virtio-rng
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
medium
high vote
Target Milestone: ovirt-4.1.0-alpha
: 4.1.0.2
Assignee: Martin Polednik
QA Contact: Nisim Simsolo
URL:
Whiteboard:
Depends On: 1074464 1347642
Blocks: 1337101 1374227 1398560 1405032
TreeView+ depends on / blocked
 
Reported: 2016-06-17 11:27 UTC by David Jaša
Modified: 2017-02-15 14:48 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
/dev/urandom is another linux backend to randomness pool. Unlike /dev/random, it does not block when entropy estimation falls below certain threshold. That doesn't mean data provided by /dev/urandom are cryptographically flawed, rather that they are older than the ones provided by /dev/random. We therefore provide /dev/urandom as RNG for virtual machines for the benefit of lower possibility of being blocked by rate limiting functionality of /dev/random.
Clone Of:
: 1374227 (view as bug list)
Environment:
Last Closed: 2017-02-15 14:48:58 UTC
oVirt Team: Virt
rule-engine: ovirt-4.1+
rule-engine: planning_ack+
tjelinek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 59031 master MERGED rng: allow urandom as virtio rng entropy source 2016-09-12 14:37:26 UTC

Description David Jaša 2016-06-17 11:27:00 UTC
Description of problem:
/dev/urandom is perfectly fine source of randomness once seeded (see bug 1074464#c13 for discussion and references) and from 7.3 on, libvirt won't refuse it as a source of randomness (see blocking bugs). oVirt/RHEV should therefore enable it as a backend for virtio-rng from 4.1 on at latest.

Version-Release number of selected component (if applicable):
4.0

How reproducible:
always

Steps to Reproduce:
1. try to use /dev/urandom as a randomnes source in Edit VM -> Random generator
2.
3.

Actual results:
only /dev/random and /dev/hwrng are available

Expected results:
/dev/urandom is available to choose as well

Additional info:

Comment 1 Red Hat Bugzilla Rules Engine 2016-06-17 11:27:37 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 3 Nisim Simsolo 2017-02-08 17:04:28 UTC
Verification build: 
ovirt-engine-4.1.0.4-0.1.el7
libvirt-client-2.0.0-10.el7_3.4.x86_64
vdsm-4.19.4-1.el7ev.x86_64
qemu-kvm-rhev-2.6.0-28.el7_3.3.x86_64
sanlock-3.4.0-1.el7.x86_64

Polarion test plan added to external tracker.


Note You need to log in before you can comment on or make changes to this bug.