Bug 134767 - View kickstart via satellite web console should use https protocol
View kickstart via satellite web console should use https protocol
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
unspecified
All Linux
medium Severity low
: ---
: ---
Assigned To: Robin Norwood
Max Spevack
:
Depends On:
Blocks: 123188
  Show dependency treegraph
 
Reported: 2004-10-06 03:03 EDT by Dean Samuels
Modified: 2007-08-06 14:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 13:57:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Samuels 2004-10-06 03:03:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040913 Firefox/0.10

Description of problem:
When viewing a configured kickstart via the RHN Satellite web console,
the link is using HTTP rather than HTTPS.  Since all other traffic
between the web browser and the RHN Satellite web console is HTTPS,
then the view kickstart link should use HTTPS too.

Version-Release number of selected component (if applicable):
rhn-3.4

How reproducible:
Always

Steps to Reproduce:
1. Configure/create kickstart profile in RHN web console
2. Click on Systems tab, kickstart link, select kickstart config, then
view kickstart
3. HTTP is used to connect
    

Actual Results:  Connection from Web browser to RHN Web console

Expected Results:  Connection from Web console to view kickstart
should be HTTPS

Additional info:
Comment 1 Robin Norwood 2004-10-06 09:35:15 EDT
The URL used by Anaconda has to be 'http://', because anaconda does
not support SSL.  However, the 'view' link can be https.

Fixed in CVS.

Test plan:  Go to the 'Details' page for a given kickstart profile. 
Note that the 'URL' field should always start with 'http://'.  The
'View' field should be a link to open the kickstart profile in a new
window, using 'https' if the server supports SSL, or 'http' if it does
not.
Comment 2 Robin Norwood 2004-10-21 12:41:56 EDT
DOC notes: We should document the fact that this link is now https://,
but that the link used by Anaconda must be http:// b/c of the fact
that anaconda does not support https
Comment 3 Todd Warner 2004-10-21 12:59:37 EDT
QA push. {ON_DEV,QA_READY} --> ON_QA
Comment 4 Max Spevack 2004-10-23 20:02:47 EDT
Ok, so the URL field is displayed in http:// and when you view it, the
URL opens in https://

From there, you can change the https:// to http:// and still view the
kickstart, so anaconda will be able to access it.
Comment 5 Clay Murphy 2004-12-03 17:14:32 EST
docs complete
Comment 6 Todd Warner 2005-03-22 13:57:38 EST
Mass move from PROD_READY to CLOSED:CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.