Bug 1347716 - Nova-client: Cannot use v2 authentication with domain scope
Summary: Nova-client: Cannot use v2 authentication with domain scope
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Pradeep Kilambi
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-17 12:51 UTC by Yurii Prokulevych
Modified: 2016-08-11 11:32 UTC (History)
13 users (show)

Fixed In Version: openstack-tripleo-heat-templates-2.0.0-24.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-11 11:32:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1599 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Release Candidate Advisory 2016-08-11 15:25:37 UTC
OpenStack gerrit 335612 None None None 2016-07-20 14:26:45 UTC
OpenStack gerrit 344864 None None None 2016-07-20 14:26:08 UTC

Description Yurii Prokulevych 2016-06-17 12:51:43 UTC
Description of problem:
Traceback in ceilometer/{central,compute}.log

2016-06-17 12:27:53.256 8202 INFO ceilometer.agent.manager [req-fe564ce7-cd5a-4651-980a-cac52c512e2f admin - - - -] Skip pollster network.outgoing.bytes, no resources found this cycle
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client [req-fe564ce7-cd5a-4651-980a-cac52c512e2f admin - - - -] Cannot use v2 authentication with domain scope
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client Traceback (most recent call last):
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client   File "/usr/lib/python2.7/site-packages/ceilometer/nova_client.py", line 52, in with_logging
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client     return func(*args, **kwargs)
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client   File "/usr/lib/python2.7/site-packages/ceilometer/nova_client.py", line 157, in instance_get_all_by_host
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client     search_opts=search_opts))
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client   File "/usr/lib/python2.7/site-packages/novaclient/v2/servers.py", line 749, in list
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client     "servers")
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client   File "/usr/lib/python2.7/site-packages/novaclient/base.py", line 242, in _list
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client     resp, body = self.api.client.get(url)
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client   File "/usr/lib/python2.7/site-packages/keystoneauth1/adapter.py", line 173, in get
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client     return self.request(url, 'GET', **kwargs)
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client   File "/usr/lib/python2.7/site-packages/novaclient/client.py", line 89, in request
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client     **kwargs)
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client   File "/usr/lib/python2.7/site-packages/keystoneauth1/adapter.py", line 331, in request
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client     resp = super(LegacyJsonAdapter, self).request(*args, **kwargs)
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client   File "/usr/lib/python2.7/site-packages/keystoneauth1/adapter.py", line 98, in request
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client     return self.session.request(url, method, **kwargs)
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client   File "/usr/lib/python2.7/site-packages/positional/__init__.py", line 94, in inner
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client     return func(*args, **kwargs)
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client   File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 370, in request
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client     auth_headers = self.get_auth_headers(auth)
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client   File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 624, in get_auth_headers
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client     return auth.get_headers(self, **kwargs)
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client   File "/usr/lib/python2.7/site-packages/keystoneauth1/plugin.py", line 84, in get_headers
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client     token = self.get_token(session)
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client   File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/base.py", line 90, in get_token
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client     return self.get_access(session).auth_token
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client   File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/base.py", line 136, in get_access
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client     self.auth_ref = self.get_auth_ref(session)
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client   File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/generic/base.py", line 179, in get_auth_ref
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client     self._plugin = self._do_create_plugin(session)
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client   File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/generic/base.py", line 168, in _do_create_plugin
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client     'Cannot use v2 authentication with domain scope')
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client DiscoveryFailure: Cannot use v2 authentication with domain scope
2016-06-17 12:37:53.227 8202 ERROR ceilometer.nova_client 

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openstack-ceilometer-api-6.0.0-2.el7ost.noarch
openstack-ceilometer-polling-6.0.0-2.el7ost.noarch
openstack-ceilometer-compute-6.0.0-2.el7ost.noarch
python-ceilometer-6.0.0-2.el7ost.noarch
openstack-ceilometer-common-6.0.0-2.el7ost.noarch
openstack-ceilometer-collector-6.0.0-2.el7ost.noarch
openstack-ceilometer-notification-6.0.0-2.el7ost.noarch
openstack-ceilometer-central-6.0.0-2.el7ost.noarch
python-ceilometerclient-2.3.0-1.el7ost.noarch

openstack-nova-api-13.0.0-8.el7ost.noarch
python-novaclient-3.3.0-1.el7ost.noarch
openstack-nova-console-13.0.0-8.el7ost.noarch
python-nova-13.0.0-8.el7ost.noarch
openstack-nova-conductor-13.0.0-8.el7ost.noarch
openstack-nova-novncproxy-13.0.0-8.el7ost.noarch
openstack-nova-common-13.0.0-8.el7ost.noarch
openstack-nova-scheduler-13.0.0-8.el7ost.noarch
openstack-nova-compute-13.0.0-8.el7ost.noarch
openstack-nova-cert-13.0.0-8.el7ost.noarch

How reproducible:


Steps to Reproduce:
1. deploy overcloud with next command:
$ openstack overcloud deploy --templates \
--control-scale 3 --compute-scale 2 --ceph-storage-scale 1 \
-e gnocchi_ceph.yaml --libvirt-type qemu --ntp-server clock.redhat.com

$ cat gnocchi_ceph.yaml 
parameter_defaults:
    GnocchiBackend: 'rbd'

Comment 1 Julien Danjou 2016-06-17 14:08:17 UTC
This happens because project_domain_name and user_domain_name are set in ceilometer.conf[service_credentials] which makes keystoneauth1 think that we are on v3, whereas it's actually v2 (likely hardcoded or by default?).

Comment 12 Yurii Prokulevych 2016-07-29 11:49:24 UTC
Auth url is fixed:
grep auth_url /etc/ceilometer/ceilometer.conf 
#auth_url = <None>
auth_url=http://192.0.2.6:5000


Compute related meters are collected at configured interval.

Verified with openstack-tripleo-heat-templates-2.0.0-24.el7ost.noarch

Comment 14 errata-xmlrpc 2016-08-11 11:32:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1599.html


Note You need to log in before you can comment on or make changes to this bug.